Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:
. every student in the committee represents a different course (a student can represent a course if he/she visits that course)
. each course has a representative in the committee
Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:
P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP
The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.
The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.
An example of program input and output:
Input
. every student in the committee represents a different course (a student can represent a course if he/she visits that course)
. each course has a representative in the committee
Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:
P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP
The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.
The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.
An example of program input and output:
2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1Output
YES NOSample Input
2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1Sample Output
YES NO
题目大概:
有很多学生,每个学生可以代表0门或多门课,问如果让一个学生只能代表一门课,是否所有课都有代表。
思路:
就是在学生和他代表的课之间建边,然后跑一遍匈牙利,求出最大匹配是否为n,来判断是否可以都有代表。
代码:
#include<iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <algorithm>
#define MAXN 500+10
using namespace std;
vector<int> G[MAXN];
int pipei[MAXN];
bool used[MAXN];
int N, M;
void init()
{
for(int i = 1; i <= N; i++)
G[i].clear();
}
void getMap()
{
scanf("%d%d",&N,&M);
init();
for(int i=1;i<=N;i++)
{
int num, y;
scanf("%d", &num);
while(num--)
{
scanf("%d", &y);
G[i].push_back(y);
}
}
}
int find(int x)
{
for(int i = 0; i < G[x].size(); i++)
{
int y = G[x][i];
if(!used[y])
{
used[y] = true;
if(pipei[y] == -1 || find(pipei[y]))
{
pipei[y] = x;
return 1;
}
}
}
return 0;
}
void solve()
{
int ans = 0;
memset(pipei, -1, sizeof(pipei));
for(int i = 1; i <= N; i++)
{
memset(used, false, sizeof(used));
ans += find(i);
}
if(ans==N)
printf("YES\n");
else printf("NO\n");
}
int main()
{
int t;
cin>>t;
while(t--)
{
getMap();
solve();
}
return 0;
}
二分图