poj 1942 Paths on a Grid

Paths on a Grid
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 24690 Accepted: 6121

Description

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b) 2=a 2+2ab+b 2). So you decide to waste your time with drawing modern art instead. 

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left: 

Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.

Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input

5 4
1 1
0 0

Sample Output

126
2

Source

提示

题意:

想象你在数学课上,你觉得很无聊,因为你几千年前就已经掌握了老师所讲的((a+b)^2=a^2+2ab+b^2)。所以你想通过画现(chou)代(xiang)艺术画来消遣。

幸运的是你有一张n*m(为32位无符号整型)方格纸,你可以像图中那样画一条从左下角到右上角的线,但是你只能向右或向上画,问有几种方式能满足条件。

思路:

我们把这一条长线分为以小方格的边为单位边的n+m个短线,其中有n个是向右,m个向上。

那么ans=c(n+m,n)或ans=c(n+m,m)

数据范围较大,我们选择n,m中比较小的来运算,用递推式显然不行,我们要用定义式来计算(下面那一个):


示例程序

Source Code

Problem: 1942		Code Length: 384B
Memory: 388K		Time: 0MS
Language: GCC		Result: Accepted
#include <stdio.h>
int main()
{
    long long n,m,i,t,sum;
    scanf("%lld %lld",&n,&m);
    while(n!=0||m!=0)
    {
        sum=1;
        if(n<m)
        {
            t=n;
            n=m;
            m=t;
        }
        for(i=n+1;n+m>=i;i++)
        {
            sum=sum*i/(i-n);
        }
        printf("%lld\n",sum);
        scanf("%lld %lld",&n,&m);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值