poj 3258 River Hopscotch

River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11671 Accepted: 5026

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distanceDi from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers:  LN, and  M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

Source

提示

题意:

河道长l(1<=l<=1000000000),其中有n个石头(0<=n<=50000),农夫John(又是你)他要利用河道让锻炼牛的跳跃力,他会把河道的m(0<=m<=n)个石头撤出,尽量使每个石头的间距变大,请输出撤出后最小的那一跳。

思路:

为什么又划分到计算方法上,看懂题意的话再加做过上一题再怎么想都是二分啊,下界为0,上界就是l,排序后sum对每个相邻石头间距做和,在没超过mid的情况下表示可以撤出石头,超出mid那就另开一组,之后与题设的m做比较,大了说明mid设的大,小了说明mid设的小。需要注意输出答案输出的是石头间最小距离,最终的间距范围在left~right之间,所以我们要输出的是left。

示例程序

Source Code

Problem: 3258		Code Length: 735B
Memory: 552K		Time: 79MS
Language: G++		Result: Accepted
#include <cstdio>
#include <algorithm>
using namespace std;
int main()
{
    int n,m,i,a[50002],l,r,k,sum,num,d;
    scanf("%d %d %d",&d,&n,&k);
    for(i=1;n>=i;i++)
    {
        scanf("%d",&a[i]);
    }
    a[0]=0;					//0为下界
    a[i]=d;					//d为上界
    l=a[0];
    r=a[i];
    sort(a+1,a+n+1);
    while(l<=r)
    {
        m=(l+r)/2;
        num=0;
        sum=0;
        for(i=0;n+1>i;i++)
        {
            if(sum+a[i+1]-a[i]<=m)				//每组石头距离之和不大于m
            {
                sum=sum+a[i+1]-a[i];
                num++;
            }
            else						//重新开一组
            {
                sum=0;
            }
        }
        if(num>k)						//组数过多说明m设的大
        {
            r=m-1;
        }
        else
        {
            l=m+1;
        }
    }
    printf("%d",l);					//这里注意要输出的是最小的距离所以要输出l,石头间距离l~r
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值