HDU - 2962 Trucking (dijkstra*2 最短路)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2962点击打开链接

Trucking

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10890    Accepted Submission(s): 957


Problem Description
A certain local trucking company would like to transport some goods on a cargo truck from one place to another. It is desirable to transport as much goods as possible each trip. Unfortunately, one cannot always use the roads in the shortest route: some roads may have obstacles (e.g. bridge overpass, tunnels) which limit heights of the goods transported. Therefore, the company would like to transport as much as possible each trip, and then choose the shortest route that can be used to transport that amount.

For the given cargo truck, maximizing the height of the goods transported is equivalent to maximizing the amount of goods transported. For safety reasons, there is a certain height limit for the cargo truck which cannot be exceeded.
 

Input
The input consists of a number of cases. Each case starts with two integers, separated by a space, on a line. These two integers are the number of cities (C) and the number of roads (R). There are at most 1000 cities, numbered from 1. This is followed by R lines each containing the city numbers of the cities connected by that road, the maximum height allowed on that road, and the length of that road. The maximum height for each road is a positive integer, except that a height of -1 indicates that there is no height limit on that road. The length of each road is a positive integer at most 1000. Every road can be travelled in both directions, and there is at most one road connecting each distinct pair of cities. Finally, the last line of each case consists of the start and end city numbers, as well as the height limit (a positive integer) of the cargo truck. The input terminates when C = R = 0.
 

Output
For each case, print the case number followed by the maximum height of the cargo truck allowed and the length of the shortest route. Use the format as shown in the sample output. If it is not possible to reach the end city from the start city, print "cannot reach destination" after the case number. Print a blank line between the output of the cases.
 

Sample Input
  
  
5 6 1 2 7 5 1 3 4 2 2 4 -1 10 2 5 2 4 3 4 10 1 4 5 8 5 1 5 10 5 6 1 2 7 5 1 3 4 2 2 4 -1 10 2 5 2 4 3 4 10 1 4 5 8 5 1 5 4 3 1 1 2 -1 100 1 3 10 0 0
 

Sample Output
  
  
Case 1: maximum height = 7 length of shortest route = 20 Case 2: maximum height = 4 length of shortest route = 8 Case 3: cannot reach destination
 

必须先最短路一遍高度 然后再最短路一遍路径

注意是必须!!

一开始的时候偷懒 把高度和路径一起判断 wa到死

之后发现一组数据 (只是举例而已)

4 4

1 2 10 10

2 3 10 10

2 3 9 9

3 4 1 1

1 4 10

很明显 高度在最后一段路决定 而如果用之前的思想 把高度的优先级大于路径 则会导致一开始选择的时候选择第二条而不选第三条 

两个不同类型的权值不应该有优先级

这里高度如果为-1 就变成卡车可以过的最大值就行


#include<iostream>
#include<algorithm>
#include<string.h>
#include<cstdio>
#include<queue>
#include<map>
#include<math.h>
#include<limits.h>
#include<vector>
#include <set>
#include <string>
using namespace std;
int c,r;
int bbegin,eend,limit;
struct xjy
{
    int num;
    int high;
    int dis;
    bool operator < (const xjy &r) const
    {
        return high<r.high;
    }
};
xjy dis[1111];
xjy mmap[1111][1111];
int book[1111];
int high;
struct cmp1
{
    bool operator ()(xjy a,xjy b)
    {
        return a.dis>b.dis;
    }
};
priority_queue<xjy>q;
priority_queue<xjy,vector<xjy >,cmp1>qq;
void dijkstrahigh(int begin)
{
    xjy mid;
    dis[begin].num=begin;
    dis[begin].high=limit;
    book[begin]=1;
    mid=dis[begin];
    q.push(mid);
    while(!q.empty())
    {
        mid=q.top();
        q.pop();
        for(int i=1;i<=c;i++)
        {
            if(!book[i]&&mmap[mid.num][i].high>-1)
            {
                if(dis[i].high<=min(mmap[mid.num][i].high,dis[mid.num].high))
                {
                        dis[i].high=min(mmap[mid.num][i].high,dis[mid.num].high);
                        dis[i].num=i;
                        q.push(dis[i]);
                }
            }
        }
        book[mid.num]=1;
    }
}


void dijkstradis(int begin)
{
    xjy mid;
    dis[begin].dis=0;
    dis[begin].num=begin;
    dis[begin].high=high;
    book[begin]=1;
    mid=dis[begin];
    qq.push(mid);
    while(!qq.empty())
    {
        mid=qq.top();
        qq.pop();
        for(int i=1;i<=c;i++)
        {
            if(!book[i]&&mmap[mid.num][i].dis<INT_MAX&&mmap[mid.num][i].high>-1)
            {
                if(mmap[mid.num][i].high>=high)
                {
                    if(dis[i].dis>mmap[mid.num][i].dis+dis[mid.num].dis)
                    {
                        dis[i].dis=mmap[mid.num][i].dis+dis[mid.num].dis;
                        dis[i].num=i;
                        qq.push(dis[i]);
                    }
                }
            }
        }
        book[mid.num]=1;
    }
}

int main()
{
    int cnt=1;
    while(~scanf("%d%d",&c,&r),c+r)
    {
        for(int i=1;i<=c;i++)
        {
            for(int j=1;j<=c;j++)
            {
                mmap[i][j].dis=INT_MAX;
                mmap[i][j].high=-1;
            }
            dis[i].dis=INT_MAX;
            dis[i].high=-1;
            book[i]=0;
        }
        for(int i=1;i<=r;i++)
        {
            int mid1,mid2,mid3,mid4;
            scanf("%d%d%d%d",&mid1,&mid2,&mid3,&mid4);
            if(mid3==-1)
                mid3=INT_MAX;
            mmap[mid1][mid2].high=mid3;
            mmap[mid2][mid1].high=mid3;
            mmap[mid1][mid2].dis=mid4;
            mmap[mid2][mid1].dis=mid4;
        }
        scanf("%d%d%d",&bbegin,&eend,&limit);
        for(int i=1;i<=c;i++)
        {
            for(int j=1;j<=c;j++)
            {
                if(mmap[i][j].high>limit)
                    mmap[i][j].high=limit;
            }
        }
        dijkstrahigh(bbegin);
        high=dis[eend].high;
        for(int i=1;i<=c;i++)
        {
            book[i]=0;
        }
        dijkstradis(bbegin);
        if(cnt!=1)
            printf("\n");
        printf("Case %d:\n",cnt++);
        if(dis[eend].dis==INT_MAX)
            cout << "cannot reach destination" << endl;
        else
        {
            cout << "maximum height = " <<dis[eend].high << endl;
            cout << "length of shortest route = " <<dis[eend].dis << endl;
        }
        
        
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值