HDU5015-233 Matrix

233 Matrix

                                                                          Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                                       Total Submission(s): 1910    Accepted Submission(s): 1141

Problem Description
In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a 0,1 = 233,a 0,2 = 2333,a 0,3 = 23333...) Besides, in 233 matrix, we got a i,j = a i-1,j +a i,j-1( i,j ≠ 0). Now you have known a 1,0,a 2,0,...,a n,0, could you tell me a n,m in the 233 matrix?
 
Input
There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 10 9). The second line contains n integers, a 1,0,a 2,0,...,a n,0(0 ≤ a i,0 < 2 31).
 
Output
For each case, output a n,m mod 10000007.
 
Sample Input
  
  
1 1 1 2 2 0 0 3 7 23 47 16
 
Sample Output
  
  
234 2799 72937
Hint
 
Source

       题意:给出矩阵的第0行(233,2333,23333,...)和第0列a1,a2,...an(n<=10,m<=10^9),给出式子: A[i][j] = A[i-1][j] + A[i][j-1],要求A[n][m]。

          解题思路:建立12*12的矩阵:

#include <iostream>
#include <stdio.h>
#include <queue>
#include <string.h>

using namespace std;

#define ll long long
#define mod 10000007

int n;
struct Matrix
{
    ll x[12][12];
    Matrix()
    {
        memset(x,0,sizeof x);
    }
}a,t;

Matrix mul(Matrix c,Matrix d)
{
    Matrix sum;
    for(int i=0;i<=n+1;i++)
    {
        for(int j=0;j<=n+1;j++)
        {
            for(int k=0;k<=n+1;k++)
            {
                sum.x[i][j]+=c.x[i][k]*d.x[k][j];
                sum.x[i][j]%=mod;
            }
        }
    }
    return sum;
}

Matrix mypow(Matrix l,int m)
{
    Matrix sum;
    for(int i=0;i<=n+1;i++)
        sum.x[i][i]=1;
    while(m)
    {
        if(m&1) sum=mul(sum,l);
        m>>=1;
        l=mul(l,l);
    }
    return sum;
}

int main()
{
    int m;
    while(~scanf("%d %d",&n,&m))
    {
        for(int i=1;i<=n;i++)
            scanf("%lld",&a.x[i][0]);
        if(m==0) {printf("%lld\n",a.x[n][0]);continue;}
        Matrix k;
        a.x[0][0]=23;
        for(int i=0;i<=n;i++)
        {
            k.x[i][0]=10;k.x[i][n+1]=1;
            for(int j=1;j<i+1;j++)
                k.x[i][j]=1;
        }
        k.x[n+1][n+1]=1;
        t=mypow(k,m);
        ll sum=0;
        for(int i=0;i<=n;i++)
        {
            sum+=(t.x[n][i]*a.x[i][0]);
            sum%=mod;
        }
        sum+=(3*t.x[n][n+1]);
        printf("%lld\n",sum%mod);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值