HDU - 5015 -233 Matrix

Problem Description
In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a 0,1 = 233,a 0,2 = 2333,a 0,3 = 23333...) Besides, in 233 matrix, we got a i,j = a i-1,j +a i,j-1( i,j ≠ 0). Now you have known a 1,0,a 2,0,...,a n,0, could you tell me a n,m in the 233 matrix?
 

Input
There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 10 9). The second line contains n integers, a 1,0,a 2,0,...,a n,0(0 ≤ a i,0 < 2 31).
 

Output
For each case, output a n,m mod 10000007.
 

Sample Input
  
  
1 1 1 2 2 0 0 3 7 23 47 16
 

Sample Output
  
  
234 2799 72937

题意:

我是看了网上某个高手的博客后,下面其地址:

点击打开链接


%2=0的是偶数
%2=1的是奇数
&1=1的是奇数
&1=0的是偶数
<<1是偶数
<<1+1是奇数

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
#define ll long long int
using namespace std;

struct matrix {
	ll mat[20][20];
	matrix(){
		memset(mat,0,sizeof(mat));
	}
	
};
int n;
matrix mul(matrix A, matrix B) {
	matrix C;
	int i, j, k;
	for ( i = 1; i <= n+2; i++)
		for ( j = 1;j <= n+2; j++)
			for ( k = 1; k <= n+2; k++) {
				C.mat[i][j] = C.mat[i][j] + A.mat[i][k] * B.mat[k][j];
						C.mat[i][j] %= 10000007;
			}
	return C;
	
}
// 转移矩阵
matrix fun(matrix A, int l) {
	matrix B;
	for (int i = 1; i<= n+2; i++) 
		B.mat[i][i] = 1;
	while (l >= 1) {
		if (l&1)
		B = mul(A,B);
		A = mul(A,A);	
		l = l / 2;
	}

	return B; // B的l次方
}

int main() {
	int m;
	while (scanf("%d%d",&n,&m) != EOF) {
		matrix A, B;
		A.mat[1][1] = 23;
		for (int i = 2;i <= n+1; i++)
			scanf("%d",&A.mat[i][1]);
		A.mat[n+2][1] = 3;
		// 刚开始的转移矩阵
		for (int i = 1; i <= n+1; i++)
			B.mat[i][1] = 10;
		for (int i = 1; i <= n+2; i++)
			B.mat[i][n+2] = 1;
		for (int i = 2; i <= n+1; i++)
			for (int j = 2;j <= i; j++)
				B.mat[i][j] = 1;

		B = fun(B,m); 
		A = mul(B,A);
	        printf("%lld\n",A.mat[n+1][1]);
	}

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值