HDU4350-Card

216 篇文章 0 订阅
100 篇文章 0 订阅

Card

                                                                             Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                                        Total Submission(s): 1504    Accepted Submission(s): 841


Problem Description
Bearchild is playing a card game with himself. But first of all, he needs to shuffle the cards. His strategy is very simple: After putting all the cards into a single stack,
he takes out some cards in the middle, from the L-th to the R-th when counting from top to bottom, inclusive, and puts them on the top. He repeats this action again 
and again for N times, and then he regards his cards as shuffled.

Given L,R and N, and the initial card stack, can you tell us what will the card stack be like after getting shuffled?
 

Input
First line contains an integer T(1 <= T <= 1000), which is the test cases.
For each test case, first line contains 52 numbers(all numbers are distinct and between 1 and 52), which is the card number of the stack, from top to bottom. 
Then comes three numbers, they are N, L and R as described. (0<=N<=10 9, 1<=L<=R<=52)
 

Output
For each test case, output "Case #X:", X is the test number, followed by 52 numbers, which is the card number from the top to bottom.Note that you should output one and only 
one blank before every number.
 

Sample Input
  
  
1 13 2 10 50 1 28 37 32 30 46 19 47 33 41 24 52 27 42 49 18 9 48 23 35 31 8 7 12 6 5 3 22 43 36 51 40 26 4 44 17 39 38 15 14 25 16 29 20 21 45 11 34 902908328 38 50
 

Sample Output
  
  
Case #1: 26 4 44 17 39 38 15 14 25 16 29 20 21 45 13 2 10 50 1 28 37 32 30 46 19 47 33 41 24 52 27 42 49 18 9 48 23 35 31 8 7 12 6 5 3 22 43 36 51 40 11 34
 

Author
elfness@UESTC_Oblivion
 

Source
 

题意:一共52个数,输入n,l,r表示把从l到r的数拿出来放到数串的最前面,如此重复n编问最后的串是什么 (n很大)
解题思路:把一个串中的 从l到r移动,每移动r次就会还原,故可对n=n%r后暴力


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>

using namespace std;

#define LL long long

int main()
{
    int cas=0,n,l,r,t;
    int a[55],b[55];
    scanf("%d",&t);
    while(t--)
    {
        for(int i=1; i<=52; i++)
            scanf("%d",&a[i]);
        scanf("%d %d %d",&n,&l,&r);
        n=n%r;
        for(int i=0;i<n;i++)
        {
            int k=0;
            for(int j=l;j<=r;j++)
                b[++k]=a[j];
            for(int j=1;j<l;j++)
                b[++k]=a[j];
            for(int j=r+1;j<=52;j++)
                b[++k]=a[j];
            for(int j=1;j<=52;j++)
                a[j]=b[j];
        }
        printf("Case #%d:",++cas);
        for(int i=1; i<=52; i++)
            printf(" %d",a[i]);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值