POJ3368-Frequent values

Frequent values
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18070 Accepted: 6508

Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

Source


题意:给出依次不下降的n个数,求某个区间内出现次数最多的数字的个数。

解题思路:类似于HDU3308,也是线段树,每个节点多记录左向右延伸几个,右向左延伸几个


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;

#define LL long long
int n,m,l,r;
int a[100005];

struct node
{
    int l,lr,r,rl,sum;
}x[400005],ans;

void Merge(node &x, node lx, node rx)
{
    x.l=lx.l,x.r=rx.r;
    x.rl=rx.rl,x.lr=lx.lr;
    if(a[lx.r]==a[rx.l]&&rx.rl==rx.r+1-rx.l) x.rl=rx.rl+lx.rl;
    if(a[lx.r]==a[rx.l]&&lx.lr==lx.r+1-lx.l) x.lr=lx.lr+rx.lr;
    x.sum=max(lx.sum,rx.sum);
    if(a[lx.r]==a[rx.l]) x.sum=max(x.sum,lx.rl+rx.lr);
}

void build(int k,int l,int r)
{
    if(l==r)
    {
        x[k].l=l;
        x[k].r=r;
        x[k].lr=1;
        x[k].rl=1;
        x[k].sum=1;
    }
    else
    {
        int mid=(l+r)>>1;
        build(k<<1,l,mid);
        build(k<<1|1,mid+1,r);
        Merge(x[k],x[k<<1],x[k<<1|1]);
    }
}

void Find(int k,int l,int r,int ll,int rr)
{
    if(ll<=l&&r<=rr)
    {
        if(ans.l==-1) ans=x[k];
        else
        {
            node pp=ans;
            Merge(ans,pp,x[k]);
        }
    }
    else
    {
        int mid=(l+r)>>1;
        if(ll<=mid) Find(k<<1,l,mid,ll,rr);
        if(rr>mid) Find(k<<1|1,mid+1,r,ll,rr);
    }
}

int solve(int l,int r)
{
    ans.l=-1;
    Find(1,1,n,l,r);
    return ans.sum;
}

int main()
{
    while(~scanf("%d",&n)&&n)
    {
        scanf("%d",&m);
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        build(1,1,n);
        while(m--)
        {
            scanf("%d %d",&l,&r);
            printf("%d\n",solve(l,r));
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值