HDU3183-A Magic Lamp

29 篇文章 0 订阅
12 篇文章 0 订阅

A Magic Lamp

                                                                               Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                          Total Submission(s): 3766    Accepted Submission(s): 1524


Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 
 

Sample Input
  
  
178543 4 1000001 1 100001 2 12345 2 54321 2
 

Sample Output
  
  
13 1 0 123 321
 

Source
 

Recommend
lcy
 
 

题意:给出一个不超过1000位的数,求删去m个数字以后形成的最小的数是多少。
解题思路:可以把题目转化一下:从A[1]、A[2]、……、A[n] n个数中选出n-m个数,使得组成的数最小。

使用RMQ,设原数字长为n,那么除去m个数字后还剩n-m个数字。因为有n-m个数字,那么在1到m+1位置中最小的那个数字必是结果中的第一个数字,记录其位置为pos,然后从这个位置的下个位置pos+1开始到m+2位置的数字中最小的那个数字必定是结果中第二个数字,以此类推下去向后找。


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;

#define LL long long

char ch[1010],ans[1020];
int dp[1010][20];

int Min(int x,int y)
{
    return ch[x]<=ch[y]?x:y;
}

void init_rmq(int len)
{
    for(int i=0; i<len; i++) dp[i][0]=i;
    for(int j=1;(1<<j)<=len;j++)
    {
        for(int i=0;i+(1<<j)-1<len; i++)
            dp[i][j]=Min(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
    }
}

int Query(int l,int r)
{
    int k=(int)(log((double)(r-l+1))/log(2.0));
    return Min(dp[l][k],dp[r-(1<<k)+1][k]);
}

int main()
{
    int m;
    while(~scanf("%s %d",ch,&m))
    {
        int len=strlen(ch);
        init_rmq(len);
        m=len-m;
        int pos=0,cnt=0;
        while(m--)
        {
            pos=Query(pos,len-m-1);
            ans[cnt++]=ch[pos++];
        }
        int i=0;
        for(; i<cnt; i++)
        {
            if(ans[i]!='0') break;
        }
        if(i==cnt) printf("0");
        else
        {
            while(i<cnt) printf("%c",ans[i++]);
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值