hdoj3183A Magic Lamp【RMQ】

A Magic Lamp

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2709    Accepted Submission(s): 1055


Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 
 

Sample Input
  
  
178543 4 1000001 1 100001 2 12345 2 54321 2
 

Sample Output
  
  
13 1 0 123 321
 

Source
 

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<list>
#include<queue>
#include<vector>
using namespace std;
const int maxn=10010;
char str[2010];
int dp[2010][20][2];//dp[i][j][0]记录i开头长度为(1<<j)的最小值;dp[i][j][1]记录最小值的最小下标 
void init(){
	int i,j,len=strlen(str);
	for(i=1;i<=len;++i){
		dp[i][0][0]=str[i-1]-'0';
		dp[i][0][1]=i;
	}
	for(j=1;j<=log2(len+1);++j){
		for(i=1;i<=len-(1<<j)+1;++i){
			if(dp[i][j-1][0]<=dp[i+(1<<(j-1))][j-1][0]){
				dp[i][j][0]=dp[i][j-1][0];
				dp[i][j][1]=dp[i][j-1][1];
			}
			else {
				dp[i][j][0]=dp[i+(1<<(j-1))][j-1][0];
				dp[i][j][1]=dp[i+(1<<(j-1))][j-1][1];
			}
		}
	}
}
int main()
{
	int i,j,k,n;
	while(scanf("%s%d",str,&n)!=EOF){
		int len=strlen(str);init();
		int l=1,r=n+1;
		bool sign=false;
		for(i=0;i<len-n;++i){
			int k=log2(r-l+1);
			int ans=min(dp[l][k][0],dp[r-(1<<k)+1][k][0]);
			if(ans)sign=true;
			if(sign){
				printf("%d",ans);
			}
			if(dp[l][k][0]<=dp[r-(1<<k)+1][k][0]){
				l=dp[l][k][1]+1;
			}
			else l=dp[r-(1<<k)+1][k][1]+1;
			r++;
		}
		if(!sign){
			printf("0\n");
		}
		else printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值