HDU6055-Regular polygon

216 篇文章 0 订阅

Regular polygon

                                                                     Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                               Total Submission(s): 685    Accepted Submission(s): 247


Problem Description
On a two-dimensional plane, give you n integer points. Your task is to figure out how many different regular polygon these points can make.
 

Input
The input file consists of several test cases. Each case the first line is a numbers N (N <= 500). The next N lines ,each line contain two number Xi and Yi(-100 <= xi,yi <= 100), means the points’ position.(the data assures no two points share the same position.)
 

Output
For each case, output a number means how many different regular polygon these points can make.
 

Sample Input
  
  
4 0 0 0 1 1 0 1 1 6 0 0 0 1 1 0 1 1 2 0 2 1
 

Sample Output
  
  
1 2
 

Source
 

题意:给你n个二维平面上的整数点,问这些整数点能形成几个正多边形

解题思路:因为是整数点,所以其实只能是正方形,然后可以枚举正方形的对角线,然后判断另外两点存不存在即可(一开始判断两点存不存在的数组开的不够大,出现越界,WA了)


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;
#define LL long long

const int INF = 0x3f3f3f3f;
const LL mod = 1e9 + 7;

struct point
{
    int x,y;
} p[505];

int n;
int vis[205][205];

int main()
{
    while(~scanf("%d",&n))
    {
        memset(vis,0,sizeof vis);
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&p[i].x,&p[i].y);
            vis[p[i].x+100][p[i].y+100]=1;
        }
        int ans=0;
        for(int i=1; i<=n; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                point tmp;
                tmp.x=(p[i].x+p[j].x+p[j].y-p[i].y);
                tmp.y=(p[i].y+p[j].y+p[i].x-p[j].x);
                if(tmp.x%2!=0||tmp.y%2!=0) continue;
                tmp.x/=2,tmp.y/=2;
                if(tmp.x < -100 || tmp.x > 100 || tmp.y < -100 || tmp.y > 100 || !vis[tmp.x+100][tmp.y+100]) continue;
                tmp.x=(p[i].x+p[j].x+p[i].y-p[j].y);
                tmp.y=(p[i].y+p[j].y+p[j].x-p[i].x);
                if(tmp.x%2!=0||tmp.y%2!=0) continue;
                tmp.x/=2,tmp.y/=2;
                if(tmp.x < -100 || tmp.x > 100 || tmp.y < -100 || tmp.y > 100 || !vis[tmp.x+100][tmp.y+100]) continue;
                ans++;
            }
        }
        printf("%d\n",ans/2);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值