HDU6205-card card card

card card card

                                                                    Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                            Total Submission(s): 1604    Accepted Submission(s): 724


Problem Description
As a fan of Doudizhu, WYJ likes collecting playing cards very much. 
One day, MJF takes a stack of cards and talks to him: let's play a game and if you win, you can get all these cards. MJF randomly assigns these cards into  n  heaps, arranges in a row, and sets a value on each heap, which is called "penalty value".
Before the game starts, WYJ can move the foremost heap to the end any times. 
After that, WYJ takes the heap of cards one by one, each time he needs to move all cards of the current heap to his hands and face them up, then he turns over some cards and the number of cards he turned is equal to the  penaltyvalue .
If at one moment, the number of cards he holds which are face-up is less than the  penaltyvalue , then the game ends. And WYJ can get all the cards in his hands (both face-up and face-down).
Your task is to help WYJ maximize the number of cards he can get in the end.So he needs to decide how many heaps that he should move to the end before the game starts. Can you help him find the answer?
MJF also guarantees that the sum of all "penalty value" is exactly equal to the number of all cards.
 

Input
There are about  10  test cases ending up with EOF.
For each test case:
the first line is an integer  n  ( 1n106 ), denoting  n  heaps of cards;
next line contains  n  integers, the  i th  integer  ai  ( 0ai1000 ) denoting there are  ai  cards in  i th  heap;
then the third line also contains  n  integers, the  i th  integer  bi  ( 1bi1000 ) denoting the "penalty value" of  i th  heap is  bi .
 

Output
For each test case, print only an integer, denoting the number of piles WYJ needs to move before the game starts. If there are multiple solutions, print the smallest one.
 

Sample Input
  
  
5 4 6 2 8 4 1 5 7 9 2
 

Sample Output
  
  
4
Hint
[pre] For the sample input: + If WYJ doesn't move the cards pile, when the game starts the state of cards is: 4 6 2 8 4 1 5 7 9 2 WYJ can take the first three piles of cards, and during the process, the number of face-up cards is 4-1+6-5+2-7. Then he can't pay the the "penalty value" of the third pile, the game ends. WYJ will get 12 cards. + If WYJ move the first four piles of cards to the end, when the game starts the state of cards is: 4 4 6 2 8 2 1 5 7 9 WYJ can take all the five piles of cards, and during the process, the number of face-up cards is 4-2+4-1+6-5+2-7+8-9. Then he takes all cards, the game ends. WYJ will get 24 cards. It can be improved that the answer is 4. **huge input, please use fastIO.** [/pre]
 

Source
 


题意:给定数列a,b,它们都有n个数,保证a数列的和等于b数列的和,计算b[i]-a[i]的前缀和c[i]。i从1到n,如果c[i]大于等于0,则可以往下继续取,否则停止,最多取到n。可以不断地就是把第一组(a[1],b[1])移至末尾,后面的元素都向前一位,问取得的最大值时需要的最小操作数。

解题思路:尺取法,两个指针指向取得头尾即可


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n;
int a[2000009], b[2000009], sm[2000009];

int main()
{
	while (~scanf("%d", &n))
	{
		int sum = 0, ma = 0;
		int ans = -1, l = 1, r = 1;
		for (int i = 1; i <= n; i++) scanf("%d", &a[i]), a[i + n] = a[i];
		for (int i = 1; i <= n; i++) scanf("%d", &b[i]), b[i + n] = b[i];
		sm[0] = 0;
		for (int i = 1; i <= 2 * n; i++) sm[i] = sm[i - 1] + a[i];
		while (l <= n)
		{
			while (sum + a[r] - b[r] >= 0 && r - l + 1 <= n)
			{
				sum += a[r] - b[r];
				r++;
			}
			if (r - l + 1 > n&&ma < sm[r - 1] - sm[l - 1])
			{
				ma = sm[r - 1] - sm[l - 1];
				ans = l - 1;
			}
			else if (r - l + 1 <= n&&ma < sm[r] - sm[l - 1])
			{
				ma = sm[r] - sm[l - 1];
				ans = l - 1;
			}
			sum -= a[l] - b[l];
			l++;
		}
		printf("%d\n", ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值