字典树+AC自动机Hyper Prefix SetsUVA11488YTACM第一周E



Pre x goodness of a set string is length of longest common pre x*number of strings in the set. For
example the pre x goodness of the set f000,001,0011g is 6.You are given a set of binary strings. Find
the maximum pre x goodness among all possible subsets of these binary strings.
Input
First line of the input contains T ( 20) the number of test cases. Each of the test cases start with n
( 50000) the number of strings. Each of the next n lines contains a string containing only `0' and `1'.
Maximum length of each of these string is 200.
Output
For each test case output the maximum pre x goodness among all possible subsets of n binary strings.
Sample Input
4
4
0000
0001
10101
010
2
01010010101010101010
11010010101010101010
3
010101010101000010001010
010101010101000010001000
010101010101000010001010
5
01010101010100001010010010100101
01010101010100001010011010101010
00001010101010110101
0001010101011010101
00010101010101001
Sample Output
6
20
66
44

ACcode:

#include <iostream>
#include<cstdlib>
#include<cstdio>
#include<string.h>
#include<cstring>
using namespace std;
#define N 50001
#define M 202

int nn,ans;
int  n,t;
struct DT//字典树结构体
{
    int chid[2];
    int num;//记录当前字符出现的次数
    void init()
    {
        num=0;
        memset(chid,-1,sizeof(chid));
    }
} dt[N*10];
char str[N][M];
void Init()//初始化
{
    nn=ans=0;
    for(int i=0; i<N*10; i++)
        dt[i].init();
}

void Insert(char s[])//插入字符串到字典树中,并寻找最佳答案
{
    int x=0;
    int chnum;
    int ls=strlen(s);
    for(int i=0; i<ls; i++)
    {
        chnum=s[i]-'0';
        if(dt[x].chid[chnum]==-1)
        {
            dt[x].chid[chnum]=++nn;
        }
        x=dt[x].chid[chnum];
        dt[x].num++;
        ans=max(ans,(i+1)*dt[x].num);//比较最大的goodness字符串前缀
    }
}
void Read()//输入
{
    for (int i=0; i<n; ++i)
    {
        scanf("%s", str[i]);
        Insert(str[i]);
    }
    return;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        Init();
        Read();
        printf("%d\n",ans);
    }
}


Running Error是开的空间不够大 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值