第5周YD督促训练 Ace of Aces

Description

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

Output

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

Sample Input

3
5
2 2 2 1 1
5
1 1 2 2 3
1
998

Sample Output

2
Nobody

998

#include <iostream>
#include<string.h>
#include<algorithm>
#include<cstdio>
using namespace std;
int main()
{
    int t,n,a[1001],max1,max11,max2,max22,x;
    cin>>t;
    while(t--)
    {
        memset(a,0,sizeof(a));
        max11=max22=max1=max2=0;
        cin>>n;
        for(int i=0; i<n; i++)
        {
            cin>>x;
            a[x]++;
        }
        for(int i=0; i<1001; i++)
        {
            if(max1<a[i])
            {
                max1=a[i];
                max11=i;
            }
            if(max2<=a[i])
            {
                max2=a[i];
                max22=i;
            }
        }
        if(max11!=max22)
            cout<<"Nobody"<<endl;
        else
            cout<<max11<<endl;
    }
    return 0;
}

#include <iostream>
#include<string.h>
#include<algorithm>
#include<cstdio>
using namespace std;
int main()
{
    int t,n,a[1001],max1,max11,max2,max22,x;
    cin>>t;
    while(t--)
    {
        memset(a,0,sizeof(a));
        max11=max22=max1=max2=0;
        cin>>n;
        for(int i=0; i<n; i++)
        {
            cin>>x;
            a[x]++;
        }
        for(int i=0; i<1001; i++) ///顺序找到最大的下标
        {
            if(max1<=a[i])
            {
                max1=a[i];
                max11=i;
            }

        }
        for(int i=1000; i>=0; i--) ///逆序找到最大的下标,而你提交错误就是因为i=1001超内存,哎,血淋淋的教训
            if(max2<=a[i])
            {
                max2=a[i];
                max22=i;
            }
        if(max11!=max22)
            cout<<"Nobody"<<endl;
        else
            cout<<max11<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值