浙江省赛 2015 -> A.Ace of Aces

Ace of Aces

Time Limit: 2 Seconds        Memory Limit: 65536 KB

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

Output

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

Sample Input
3
5
2 2 2 1 1
5
1 1 2 2 3
1
998
Sample Output
2
Nobody
998
 
 
这是一道找最大相同字符数的小水娃娃~
//code 如下。
 

#include<cstdio> #include<string.h> #include<algorithm> #include<iostream> #include<math.h> using namespace std;

int a[1010];

int main(){ int n;cin>>n; for(int i=0;i<n;i++){

    int m;     scanf("%d",&m);     for(int j=0;j<m;j++)         cin>>a[j];     sort(a,a+m);     int l=0,t=0,s=0;     int error=0;     for(int j=0;j<m;){

        int k=j+1;         while(a[j]==a[k]&&k<m)  k++;         s=k-j;         if(s==l) {error=1;}         if(s>l) {l=s;t=j;error=0;}

        j=j+s;

    }  if(error)  printf("Nobady\n");         else   printf("%d\n",a[t]);

        }

   return 0;

 

}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值