ZOJ 3869 结构体排序

Ace of Aces

Time Limit: 2 Seconds       Memory Limit: 65536 KB

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

Output

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

Sample Input
3
5
2 2 2 1 1
5
1 1 2 2 3
1
998
Sample Output
2
Nobody
998


遇到的问题和思路:

        首先看到这道题,第一反应不是结构体排序,只是感觉是单纯的一道题目,然后用很普通的代码就OK了。

        然后看了一下别人的代码,然后就按照着他们的样子,把代码打上去的。这里要增加一个知识,和sort有关的。


bool cmp(int a, int b){ return a > b(这个就是降序)}   如果是return a < b  这个就是升序。但是注意一点,如果是用结构体的话,那么前面是const + 结构体名字 + &a和const + 结构体名字 + &b

sort(a, a + n, cmp)函数(因为是根据代码习惯,所以cmp写上方)



下面先给出我没有用结构体就过了的代码:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<queue>
#include<algorithm>

using namespace std;

int n;
int vot[1005];
int ans[1005];

void solve(){
	int res = 0,num = -1,coun = 1;
	for(int i = 0; i < 1001; i++){
		if(vot[i] != -1)ans[vot[i]]++;
	}
	for(int i = 0; i < 1001; i++){
		if(ans[i] > res){
			res = ans[i];
			num = i;
			coun = 1;
		}
		else if(ans[i] == res){
			coun++;
		}
	}
	if(coun < 2)printf("%d\n",num);
	else printf("Nobody\n");
}

int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		scanf("%d", &n);
		memset(vot, -1, sizeof(vot));
		memset(ans, 0, sizeof(ans));
		for(int i = 0; i < n; i++){
			scanf("%d",&vot[i]);
		}
		solve();
	}
	return 0;
}


下面给出用结构体的代码:


#include<cstdio>
#include<cmath>
#include<cstring>
#include<queue>
#include<algorithm>

using namespace std;

int n;
struct vot{
	int vote;
	int num;
}aim[1005];

bool compa(const vot &a,const vot &b){
	return b.vote < a.vote;
}

int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		memset(aim, 0, sizeof(aim));
		scanf("%d", &n);
		int f;
		for(int i = 0; i < n; i++){
			scanf("%d",&f);
			aim[f].vote++;
			aim[f].num = f;
		}
		sort(aim, aim + 1001, compa);
		if(aim[0].vote == aim[1].vote)printf("Nobody\n");
		else printf("%d\n", aim[0].num);
		
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值