贪心-H Wooden Sticks

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute. (b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l<=l’ and w<=w’. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, …, ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

Sample Output

2
1
3

题意是生产n个木棍,每个木棍有长度和重量,如果后一个木棍的长度和重量都比上一个大,则不需要重新调试机器,否则需要花一分钟进行调试机器,求生产这些木棍所需要的最短时间。
现将这些木棍按照长度从小到大排序,若长度一样则按重量从小到大排序。因为长度已经排好序,所以不用考虑。只需要比较后一个比前一个的重量,若小,则sum加一。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct stick
{
    int length;
    int weight;
}a[10000];
bool cmp(stick a,stick b)
{
    if(a.length==b.length)
    return a.weight<b.weight;
    else
    return
    a.length<b.length;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        int book[10000]={0};
        int sum=0;
        cin>>n;
        for(int i=0;i<n;i++)
        cin>>a[i].length>>a[i].weight;
        sort(a,a+n,cmp);
        for(int i=0;i<n;i++)
        {
            if(book[i])
            continue;
            int max=a[i].weight;
            for(int j=i+1;j<n;j++)//长度已经排好序,只需要比较后一个的重量是否比前一个大
            {
                if(!book[j]&&a[j].weight>=max)
                {
                    book[j]=1;
                    max=a[j].weight;
                }
            }
            sum++;
        }
        cout<<sum<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值