区间DP-J Multiplication Puzzle

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10150 + 50205 + 10505 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
15020 + 1205 + 1015 = 1000+100+50 = 1150.
Input
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output
Output must contain a single integer - the minimal score.
Sample Input
6
10 1 50 50 20 5
Sample Output
3650
题意是给n个数字,除去第一个和最后一个外取一个数,得分等于取出来的数乘以其左边和右边的数,一直取到还剩两个数,求最小得分和。
定义dp[i][j](j-i>=2)为序列num[i…j]在该规则下的最优解,可选的值为num[i+1]到num[j-1],(注意这里 num[i]和num[j]是不可取的) 我们取一个k(i < k <j),则取出k时的得分为num[i]*num[k]*num[j],则此时dp[i][j] = dp[i][k] + dp[k][j] + num[i]*num[k]*num[j]。所以状态转移方程为dp[i][j] = min(dp[i][k] + dp[k][j] +num[i]*num[k]*num[j]) (i+1<=k<=j-1) 。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int num[105];
int dp[105][105];
int main()
{
    int n;
    while(cin>>n)
    {
        for(int i=1;i<=n;i++)
        cin>>num[i];
        memset(dp,0,sizeof(dp));
        for(int len=2;len<n;len++)
        {
            for(int i=1;i+len<=n;i++)
            {
                int j=i+len;
                dp[i][j]=0x3f3f3f3f;
                for(int k=i+1;k<=j-1;k++)
                {
                    dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]+num[i]*num[k]*num[j]);
                }
            }
        }
        cout<<dp[1][n]<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值