UVa 10189 SDNU 1127 Minesweeper 【7月20】

Minesweeper

原题贴上,不给链接了。

Description

Have you ever played Minesweeper? It's a cute little game which comes within a certain Operating System which name we can't really remember. Well, the goal of the game is to find where are all the mines within a MxN field. To help you, the game shows a number in a square which tells you how many mines there are adjacent to that square. For instance, supose the following 4x4 field with 2 mines (which are represented by an * character):

*...
....
.*..
....
If we would represent the same field placing the hint numbers described above, we would end up with:

*100
2210
1*10
1110
As you may have already noticed, each square may have at most 8 adjacent squares.

Input

The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m (0 < n,m <= 100) which stands for the number of lines and columns of the field respectively. The next n lines contains exactly m characters and represent the field. Each safe square is represented by an "." character (without the quotes) and each mine square is represented by an "*" character (also without the quotes). The first field line where n = m = 0 represents the end of input and should not be processed.

Output

For each field, you must print the following message in a line alone:

Field #x:

Where x stands for the number of the field (starting from 1). The next n lines should contain the field with the "." characters replaced by the number of adjacent mines to that square. There must be an empty line between field outputs.

Sample Input

4 4
*...
....
.*..
....
3 5
**...
.....
.*...
0 0

Sample Output

Field #1:
*100
2210
1*10
1110

Field #2:
**100
33200
1*100
 
  
本来以为是什么高大上的题目。。。翻译完了才明白。。。既然翻译了,就A了吧~
题目意思就是给你一个方阵,“*”代表地雷,然后根据扫雷那样的原则,写出那些该有的数字。。就这样。。思路很清楚,“*”周围的八个位置+1贴代码:
#include<cstdio>
#include<iostream>
using namespace  std;
int main()
{
    int m,n,kase=0;
    while(scanf("%d%d",&m,&n)==2&&m+n){
        if(kase!=0) printf("\n");
        char g[110][110];
        int f[110][110]={0};
        for(int i=1;i<=m;i++)
        for(int j=1;j<=n;j++){
            cin>>g[i][j];
            if(g[i][j]=='*')
            for(int p=-1;p<2;p++)
                for(int q=-1;q<2;q++)
                        f[i+p][j+q]++;
        }
        printf("Field #%d:\n",++kase);
        for(int i=1;i<=m;i++){
            for(int j=1;j<=n;j++){
                if(g[i][j]=='*') printf("*");
                else cout<<f[i][j];
            }
            printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值