Minesweeper UVA- 这尼玛坑爹的空行

UVA上的大水,和扫雷游戏一样,结果WA了2次!!!!就是因为没有处理好结尾空行的问题,也算是个教训吧,再一次被UVA强大的后台检测给黑到了

注意的就是把数组开大一点,然后空行的换是第二字数据输出 空行+数据,而不是一组数据出来之后直接出空行,这样的话数据结尾会多一个空行,就会WA

The Problem

Have you ever played Minesweeper? It's a cute little game which comes within a certain Operating System which name we can't really remember. Well, the goal of the game is to find where are all the mines within a MxN field. To help you, the game shows a number in a square which tells you how many mines there are adjacent to that square. For instance, supose the following 4x4 field with 2 mines (which are represented by an * character):

*...
....
.*..
....
If we would represent the same field placing the hint numbers described above, we would end up with:
*100
2210
1*10
1110
As you may have already noticed, each square may have at most 8 adjacent squares.

The Input

The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m (0 < n,m <= 100) which stands for the number of lines and columns of the field respectively. The next n lines contains exactly m characters and represent the field. Each safe square is represented by an "." character (without the quotes) and each mine square is represented by an "*" character (also without the quotes). The first field line where n = m = 0 represents the end of input and should not be processed.

The Output

For each field, you must print the following message in a line alone:

Field #x:
Where x stands for the number of the field (starting from 1). The next n lines should contain the field with the "." characters replaced by the number of adjacent mines to that square. There must be an empty line between field outputs.

Sample Input

4 4
*...
....
.*..
....
3 5
**...
.....
.*...
0 0

Sample Output

Field #1:
*100
2210
1*10
1110

Field #2:
**100
33200
1*100


#include<stdio.h>
#include<string.h>
#define MAX_SIZE 100 + 10
int main()
{
    char maps[MAX_SIZE][MAX_SIZE];
    int i,j,m,n,sum;
    int cases=1;
    for(;scanf("%d%d",&m,&n);)
    {
        memset(maps,'.',sizeof(maps));
        if(!m&&!n)
          break;
        getchar();
        for(i=1;i<=m;i++)
           {
            for(j=1;j<=n;j++)
             maps[i][j]=getchar();
             getchar();
           }
        if(cases>1)printf("\n");
        printf("Field #%d:\n",cases);
        for(i=1;i<=m;i++)
        {
            for(j=1;j<=n;j++)
        {
            sum=0;
            if(maps[i][j]=='*')
                printf("*");
            else
            {
                if(maps[i+1][j]=='*')
                    sum++;
                if(maps[i-1][j]=='*')
                    sum++;
                if(maps[i][j+1]=='*')
                    sum++;
                if(maps[i][j-1]=='*')
                    sum++;
                if(maps[i+1][j+1]=='*')
                    sum++;
                if(maps[i+1][j-1]=='*')
                    sum++;
                if(maps[i-1][j+1]=='*')
                    sum++;
                if(maps[i-1][j-1]=='*')
                    sum++;
                printf("%d",sum);
            }
        }
        printf("\n");
        }
        cases++;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值