maven使用mvn archetype:generate命令创建项目骨架遇到的问题

使用如下命令-使用项目骨架创建一个maven项目:

mvn archetype:generate \
    -DarchetypeGroupId=org.apache.flink \
    -DarchetypeArtifactId=flink-quickstart-java \
    -DarchetypeCatalog=https://repository.apache.org/content/repositories/snapshots/ \
    -DarchetypeVersion=1.3-SNAPSHOT \
    -DgroupId=wiki-edits \
    -DartifactId=wiki-edits \
    -Dversion=0.1 \
    -Dpackage=wikiedits \
    -DinteractiveMode=false

报错:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:3.0.1:generate (default-cli) 
on project standalone-pom: archetypeCatalog 'https://repository.apache.org/content/repositories/snapshots/' is not supported anymore. Please read the plugin documentation for details. -> [Help 1]
[ERROR] 

一开始觉得是仓库有问题,但是换了仓库同样报错,最后觉得应该是和maven-archetype-plugin版本有关:
使用2.4版本执行:

mvn org.apache.maven.plugins:maven-archetype-plugin:2.4:generate -DarchetypeCatalog=https://repository.apache.org/content/repositories/snapshots/

发现可以成功执行。
使用3.0.1版本执行,发现报同样的错:

mvn org.apache.maven.plugins:maven-archetype-plugin:3.0.1:generate -DarchetypeCatalog=https://repository.apache.org/content/repositories/snapshots/

于是使用指定插件版本的命令:

mvn org.apache.maven.plugins:maven-archetype-plugin:2.4:generate\
     -DarchetypeGroupId=org.apache.flink \
     -DarchetypeArtifactId=flink-quickstart-java \
     -DarchetypeCatalog=https://repository.apache.org/content/repositories/snapshots/ \
     -DarchetypeVersion=1.3-SNAPSHOT \
     -DgroupId=wiki-edits \
     -DartifactId=wiki-edits \
     -Dversion=0.1 \
     -Dpackage=wikiedits \
     -DinteractiveMode=false

BUILD SUCCESS。

  • 7
    点赞
  • 13
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值