Second My Problem First HDOJ 5th Anniversary Contest 1007

Second My Problem First

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1272    Accepted Submission(s): 212

Problem Description
Give you three integers n, A and B.
Then we define S i = A i mod B and T i = Min{ S k | i-A <= k <= i, k >= 1}
Your task is to calculate the product of T i (1 <= i <= n) mod B.
 

 

Input
Each line will contain three integers n(1 <= n <= 10 7),A and B(1 <= A, B <= 2 31-1).
Process to end of file.
 

 

Output
For each case, output the answer in a single line.
 

 

Sample Input
  
  
1 2 3 2 3 4 3 4 5 4 5 6 5 6 7
 

 

Sample Output
  
  
2 3 4 5 6
 

 

Author
相似题目:pku Sliding window
单调队列处理查询是递增的区间最小值

#include<iostream>

using namespace std;

#define N 10000000

int n;

struct QU

{

    int pos;

    __int64 value;

}Q[N];

 

int main()

{

    __int64 a,b,t,i,ans,minn,ss;

    while(scanf("%I64d%I64d%I64d",&n,&a,&b)!=EOF)

    {

        int head=1;

        int tail=0;

        t=a;

        ans=1;

        minn=a;

        for(i=1;i<=n&&a!=1;i++)

        {

            ss=a%b;

            while(head<=tail&&ss<Q[tail].value)

                tail--;

            while(head<=tail&&Q[head].pos<i-t)

                head++;

            Q[++tail].value=ss;

            Q[tail].pos=i;

            ans=(ans*Q[head].value)%b;

 

            a=(a*t)%b;

        }

        printf("%I64d/n",ans);

    }

}

 

 
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值