HDU-1358 Period

Problem: Period HDU-1358

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it. 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case. 

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

思路:

  • 先求出该字符串在一个下标处失配需要回溯的到下标的next数组(这里若不知道可以先看KMP模式匹配算法)
  • 我们可以发现一个周期性数组 j%(j-next[j])==0 就是一个周期数组,其中j为失配下标,其周期为j/(j-next[j]),我们可以画图来解释一下上述推论
  • 若是一个周期性数组,如下图
  • 若不是一个周期性数组,如下图

 AcCode:

import java.util.Scanner;

public class Main{
	//得到一个next数组
	public static int[] getNext(String subStr) {
		int[] next = new int[subStr.length()+1];
		next[0] = -1;
		//递推得到next数组
		int j = 0;
		int temp = j;
		while(j<next.length-1) {
			int k = next[temp];
			if(k<0 || subStr.charAt(j)==subStr.charAt(k)) {
				next[++j] = k+1;
				temp = j;
			}else {//不相等继续回溯
				temp = k;
			}
		}
		return next;
	}
	//打印周期前缀的大小和周期
	public static void getPeriod(int[] next) {
		for (int j = 1; j < next.length; j++) {
			int k = next[j];
			if(j%(j-k)==0 && (j/(j-k))>1) {
				System.out.println(j+" "+(j/(j-k)));
			}
		}
	}
	
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int num = 1;
		while(true) {
			int n = in.nextInt();
			if(n==0) {
				break;
			}
			String subStr = in.next();
			System.out.println("Test case #"+num);
			getPeriod(getNext(subStr));
			num++;
			System.out.println();
		}
	}
	
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值