Crossing River (POJ - 1700)

Crossing River

 POJ - 1700 

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17

思路:

  • 贪心
  • 第一种贪心策略:每次都使用最小的去送当前最大的,然后最小的回来继续送
  • 第二种贪心策略:先将最小的两个送过去,将次小的留在对岸,最小的返回来,然后将两个最大的送过去,将上次次小的返回来
  • 两个贪心策略渡河所花费的时间都可能是最小的,要取最小值

AcCode:

import static java.lang.Math.min;

import java.util.Arrays;
import java.util.Scanner;

public class Main{
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int T = in.nextInt();
		while(T!=0) {
			int N = in.nextInt();
			int[] speads = new int[N];
			for (int i = 0; i < speads.length; i++) {
				speads[i] = in.nextInt();
			}
			Arrays.sort(speads);
			f(speads,speads.length-1);
			T--;
		}
	}

	private static void f(int[] speads, int index) {
		int res = 0;
		while(index>=0) {
			if(index==0) {
				res+=speads[0];
				break;
			}else if(index==1) {
				res+=speads[1];
				break;
			}else if(index==2) {
				res+=speads[0]+speads[1]+speads[2];
				break;
			}else {
				//1.1-4,1-3,1-2
				int solve1 = speads[index]+speads[index-1]+2*speads[0];
				//2.1-2,3-4,1-2
				int solve2 = speads[0]+speads[1]+speads[index]+speads[1];
				res+=min(solve1, solve2);
				index-=2;
			}
		}
		System.out.println(res);
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值