Crossing River (poj 1700)

Crossing River

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won’t be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input
1
4
1 2 5 10
Sample Output
17

一道很好玩的贪心题,不太好做哦,(我第一次是没做出来,哈哈)。
题意就是有n个人需要过河,每个人都具有一个过河时间。然而只有一条船,船只能坐两个人,船过河的时间为船上两人中过河时间长的时间,求所有人过河的最小时间。
一定要知道,两人坐船到对岸后,还需要有人把船开回来,这样才能让剩下的人也坐船过河
先按时间从小到大排序一下
emmm,怎么做呢, 首先想的是每次让时间最短的那个人的和其他人一起过河,然后再让他把船开回来继续接其他人?那时间就是a[1]+a[2]+…a[n-1]+(n-2)*a[0],但是还有一种最快的和次快的过河, 最快的将船划回来, 再当前最慢和次慢的一起过河,次快的将船划回来.(完成了将当前最慢和次慢送过河)这样就是a[-1]*2+a[0]+a[n-1],有可能会比每次让最快来回送人快哦,(a[n-1]+a[0]*2+a[n-2]),所以每次送人时,可以取这两种的min值,总人数减2,求下去就好了,可以自己模拟一下,两边所说的两种送人过河的方式

看代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int t,a[1200],n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		scanf("%d",&a[i]);
		sort(a,a+n);//按时间从小到大排序
		int sum=0;
		while(n)
		{
			if(n==1)
			{sum+=a[0];break;}//一人过河时间当然就是他自己了,不需要把船开回来
			else if(n==2)
			{sum+=a[1];break;}//两人过河就慢的那个时间,同样不需要把船开回来
			else if(n==3)
			{sum+=(a[0]+a[1]+a[2]);break;}//让最快送最慢,最快再把船开回来,接次慢
			else 
			{sum+=min(a[1]*2+a[0]+a[n-1],a[n-1]+a[0]*2+a[n-2]);n-=2;}//每次送两人过河,取两种方式的最小值,精髓
		}
		printf("%d\n",sum);
	}
	return 0;
} 
评论 7
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值