hdu 1385 Minimum Transport Cost(最短路+输出路径)

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9805    Accepted Submission(s): 2636


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
题意:给你一幅图,在给你每个点的权值,每次经过一个中间点(不算起点和中点)都要加上这个中间点的权值,让你求出最短路,还有输出最短路径

思路: 由于循环是任意两点,可以想到用floyd求任意两点间最短路,但是路径怎么办呢? 我们可以用一个path数组保存中间点,比如path[i][j]=k表示在从i到j的最短路上经过k,且k是i到j的路径上第一个点,这个可以通过floyd松弛操作时进行构造。 有了这个数组,我们只要从path[s][t]开始,每次把第一个中间点设为起始点,直到等于终点就能输出路径了。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 101
#define INF 1<<28
int n;
int ma[N][N];
int d[N][N];
int v[N],path[N][N];
void floyd()
{
    for(int k=0; k<n; k++)
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                {
                    if(i==k||i==j||j==k) continue;
                    if(d[i][j]>d[i][k]+d[k][j]+v[k])
                    {
                        d[i][j]=d[i][k]+d[k][j]+v[k];
                        path[i][j]=path[i][k];
                    }
                    else if(d[i][j]==d[i][k]+d[k][j]+v[k])
                    {
                        if(path[i][j]>path[i][k])
                            path[i][j]=path[i][k];
                    }
                }
}

void print_path(int u,int v) //u是起点v是终点
{
    int k;
    if(u==v)
    {
        printf("%d",v+1);
        return ;
    }
    k=path[u][v];
    printf("%d-->",u+1);
    print_path(k,v);
}
int main()
{
    int s,e;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                scanf("%d",&ma[i][j]);
                if(ma[i][j]==-1)
                    ma[i][j]=INF;
                    path[i][j]=j;
            }
        for(int i=0; i<n; i++)
            scanf("%d",&v[i]);
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                d[i][j]=ma[i][j];
        floyd();
        while(scanf("%d %d",&s,&e)&&(s!=-1))
        {
            printf("From %d to %d :\n",s,e);
            s--,e--;
            if(s==e)
                printf("Path: %d\n",s+1);
            else
            {
                printf("Path: ");
                print_path(s,e);
                printf("\n");
            }
            printf("Total cost : %d\n\n",d[s][e]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值