hdu 5166 Missing number(模拟)

Missing number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1018    Accepted Submission(s): 517


Problem Description
There is a permutation without two numbers in it, and now you know what numbers the permutation has. Please find the two numbers it lose.
 

Input
There is a number  T  shows there are  T  test cases below. ( T10 )
For each test case , the first line contains a integers  n  , which means the number of numbers the permutation has. In following a line , there are  n  distinct postive integers.( 1n1,000 )
 

Output
For each case output two numbers , small number first.
 

Sample Input
  
  
2 3 3 4 5 1 1
 

Sample Output
  
  
1 2 2 3
题意:有一个n+2的连续序列,现在从中挖去两个数变成n个数字,求补上哪两个数字可以组成连续序列,这两个数字要尽量小

思路:初始序列不是排好序的。。注意。 然后直接模拟就好了,输入保证插入两个数一定可以组成

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 1050
int a[N];
int ans[3];
int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
            sort(a+1,a+1+n);
        int num=0;
        if(a[n]-a[1]+1==n)
        {
            if(a[1]>2) printf("%d %d\n",a[1]-2,a[1]-1);
            else if(a[1]==2) printf("1 %d\n",a[n]+1);
            else printf("%d %d\n",a[n]+1,a[n]+2);
        }
        else
        {
            for(int i=1; i<n; i++)
            {
                if(a[i]+2==a[i+1])
                        ans[num++]=a[i]+1;
                else if(a[i]+3==a[i+1])
                {
                    ans[num++]=a[i]+1;
                    ans[num++]=a[i]+2;
                }
                if(num>=2)
                    break;
            }
            if(num==1)
            {
                if(a[1]==1)
                    printf("%d %d\n",ans[0],a[n]+1);
                else
                    printf("1 %d\n",ans[0]);
            }
            else printf("%d %d\n",ans[0],ans[1]);
        }
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值