hdu 5190 Go to movies(水)

Go to movies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1028    Accepted Submission(s): 542


Problem Description
Winter holiday is coming!As the monitor, LeLe plans to go to the movies.
Because the winter holiday tickets are pretty expensive, LeLe decideds to try group-buying.
 

Input
There are multiple test cases, about  20  cases. The first line of input contains two integers  n,m(1n,m100) n  indicates the number of the students.  m indicates how many cinemas have offered group-buying.

For the  m  lines,each line contains two integers  ai,bi(1ai,bi100) , indicating the choices of the group buying cinemas offered which means you can use  bi yuan to buy  ai  tickets in this cinema.
 

Output
For each case, please help LeLe **choose a cinema** which costs the least money. Output the total money LeLe should pay.
 

Sample Input
  
  
3 2 2 2 3 5
 

Sample Output
  
  
4
Hint
LeLe can buy four tickets with four yuan in cinema 1.
题意:给你n个学生和m个电影院,每个电影院可以用b元买a张票

问你哪个电影院可以话最少元买到n个学生的票,输出价钱

思路:水题,直接模拟

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define INF 999999999
int main()
{
    int n,m;
    int a,b;
    while(~scanf("%d %d",&n,&m))
    {
        int ans=INF;
        for(int i=1;i<=m;i++)
            {
                scanf("%d %d",&a,&b);
                int cost=n/a;
                if(n%a!=0) cost++;
                ans=min(ans,cost*b);
            }
            printf("%d\n",ans);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值