hdu-6197 array array array(最长上升子序列(LIS)长度的O(nlogn)算法)

Problem Description
One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo’s path to escape from the museum. But Kiddo didn’t want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum.
Kiddo: “I have an array A and a number k, if you can choose exactly k elements from A and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say A is a magic array. Now I want you to tell me whether A is a magic array. ” Conan: “emmmmm…” Now, Conan seems to be in trouble, can you help him?

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with two integers n and k in one line, then one line with n integers: A1,A2…An.
1≤T≤20
1≤n≤105
0≤k≤n
1≤Ai≤105

Output
For each test case, please output “A is a magic array.” if it is a magic array. Otherwise, output “A is not a magic array.” (without quotes).

Sample Input
3
4 1
1 4 3 7
5 2
4 1 3 1 2
6 1
1 4 3 5 4 6

Sample Output
A is a magic array.
A is a magic array.
A is not a magic array.
最长上升子序列(LIS)长度的O(nlogn)算法:http://blog.csdn.net/shuangde800/article/details/7474903
求出最长上升或下降子序列长度为a,如果a>=n-k,则为magic array。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define N 100010
#define LL long long

using namespace std;

const LL mod=1000000007;
int num[N],dp[N];

int Search(int len, int key)
{
    int l=0,r=len-1;
    while (l<=r)
    {
        int mid=(l+r)/2;
        if (dp[mid]>key)
        {
            r=mid-1;
        }
        else if (dp[mid]<key)
        {
            l=mid+1;
        }
        else
        {
            return mid;
        }
    }
    return l;
}

int main()
{
    int t,n,k;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        for (int i=0;i<n;i++)
        {
            scanf("%d",&num[i]);
        }
        int len=1;
        dp[0]=num[0];
        for (int i=1;i<n;i++)
        {
            if (num[i]>dp[len-1])
            {
                dp[len]=num[i];
                len++;
            }
            else
            {
                int pos=Search(len,num[i]);
                dp[pos]=num[i];
            }
        }
        int lena=len;
        for (int i=0;i<n;i++)
        {
            num[i]=-num[i];
        }
        len=1;
        dp[0]=num[0];
        for (int i=1;i<n;i++)
        {
            if (num[i]>dp[len-1])
            {
                dp[len]=num[i];
                len++;
            }
            else
            {
                int pos=Search(len,num[i]);
                dp[pos]=num[i];
            }
        }
        int lenb=len;
        if (max(lena,lenb)>=n-k)
        {
            printf("A is a magic array.\n");
        }
        else
        {
            printf("A is not a magic array.\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值