『1141』PAT Ranking of Institutions

After each PAT, the PAT Center will announce the ranking of institutions based on their students’ performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School

where ID is a string of 6 characters with the first one representing the test level: B stands for the basic level, A the advanced level and T the top level; Score is an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); ; TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:

10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

Sample Output:

5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

Ω

为PAT的团体成绩进行排序,给出每个考生的准考证号、成绩、学校代号,最终学校团体成绩按照 ,ABT代表三个不同的考试等级, 表示这个学校参加X等级考试的考生成绩总和。最终结果按团体成绩降序排列,并给出相应名次,如果总成绩相同就按照参与人数的升序排列,如果人数也一致就按照学校代码升序排列。

先用一个map<string, tuple<int, int, int, int>>建立学校代码到BAT考试成绩总和以及考生人数的映射。然后计算每个学校的团体成绩,并将学校代码、考生人数一并存入vector<tuple<string, int, int>>,然后根据排序要求给定cmp函数进行sort。最后依次输出相关信息。如果团体成绩与上一个学校一样,那么名次不变,否则=下标+1。


Ω

#include <iostream>
#include <map>
#include <vector>
#include <algorithm>

using namespace std;
typedef tuple<string, int, int> tsii;

int main()
{
    string id, school;
    int n, s, r = 0, p = -1;
    cin >> n;
    map<string, tuple<int, int, int, int>> score;
    for (int i = 0; i < n; ++i)
    {
        cin >> id >> s >> school;
        transform(school.begin(), school.end(), school.begin(), ::tolower);
        switch (id[0])
        {
            case 'B':
                get<0>(score[school]) += s;
                break;
            case 'A':
                get<1>(score[school]) += s;
                break;
            case 'T':
                get<2>(score[school]) += s;
                break;
        }
        ++get<3>(score[school]);
    }
    vector<tsii> tws;
    for (auto &t: score)
        tws.emplace_back(t.first, get<0>(t.second) / 1.5 + get<1>(t.second) + get<2>(t.second) * 1.5, get<3>(t.second));
    sort(tws.begin(), tws.end(), [](tsii &a, tsii &b) {return get<1>(a) == get<1>(b) ?
          make_pair(get<2>(a), get<0>(a)) < make_pair(get<2>(b), get<0>(b)) : get<1>(a) > get<1>(b);});
    printf("%zu\n", tws.size());
    for (int i = 0; i < tws.size(); ++i)
    {
        r = (get<1>(tws[i]) == p) ? r : (p = get<1>(tws[i]), i + 1);
        printf("%d %s %d %d\n", r, get<0>(tws[i]).c_str(), get<1>(tws[i]), get<2>(tws[i]));
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值