POJ2478 Farey Sequence(欧拉函数)

题目链接

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

这道题的大致意思就是给你一个整数n,要你求2到n做为分母,含有的最简分数的个数为多少?
最简分数,它分母和分子的最小公倍数是1,分子和分母是互质的,是不是很熟悉,就是欧拉函数,那么我们能够很清楚的知道这道题就是让你去求2到n这些分母的欧拉函数,然后将它们加起来就可以了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn=1e6+100;
LL phi[maxn];
LL sum[maxn];
void init(){
	for(int i=1;i<maxn;i++)phi[i]=i;
	for(int i=2;i<maxn;i++){
		if(phi[i]==i){
			for( int j=i;j<maxn;j+=i)
			phi[j]=phi[j]/i*(i-1);
		}
	}
	sum[1]=0;
	for(int i=2;i<maxn;i++){
		sum[i]=sum[i-1]+phi[i];
	}
}
int main(){
	init();
	int n;
	while(~scanf("%d",&n)&&n){
		printf("%lld\n",sum[n]);
	}
}

道阻且长
自己选的路 跪着也要走完

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值