Farey Sequence(欧拉函数&&素数筛法)

题目链接
Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.
Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.
Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.
Sample Input

2
3
4
5
0
Sample Output

1
3
5
9
**题意:**给一个数 n,对于序列 Fn,其是不可约分的有理数 a/b 的集合,其中 0 <a <b <= n 且 GCD(a,b)=1

思路:
素数筛法+欧拉函数

观察序列,每次 n 增大 1,序列添加的个数就是分子与分母互质的个数,问题即为求小于 n 的与 n 互质的数的个数的和,即求欧拉函数从 2 到 n 的和。

先打表求欧拉函数,再用一数组存储所有欧拉函数的和,最后输出即可。

#include <iostream>
#include <algorithm>
#include <cmath>
#include <ctype.h>
#include <cstring>
#include <cstdio>
#include <sstream>
#include <cstdlib>
#include <iomanip>
#include <string>
#include <queue>
#include <map>

using namespace std;

#define maxn 1000005
#define INT __int64
int Prime[maxn+1];
INT ans[maxn+1];

void prime()//素数表0是素数1为合数
{
    memset(Prime,0,sizeof(Prime));
    Prime[0]=Prime[1]=1;
    for(int i=2;i*i<=maxn;++i)
    {
        if(!Prime[i])
        {
            for(int j=i*i;j<=maxn;j+=i)
                Prime[j]=1;
        }
    }
}
void eulerfun()
{
    for(int i=1;i<=maxn;++i)
        ans[i]=i;
    for(int i=2;i<=maxn;i++)
    {
        if(!Prime[i])
            for(int j=i;j<=maxn;j+=i)
                ans[j]=ans[j]/i*(i-1);
    }
}
int main()
{
    int n;
    prime();
    eulerfun();
    for(int i=3;i<=maxn;++i)
        ans[i]+=ans[i-1];
    while(~scanf("%d",&n)&&n)
        printf("%I64d\n",ans[n]);
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值