A + B Problem II

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

这是很经典的题,大数加法,先输入两个字符串,然后将两个字符串分别逆序存储到两个整型数组里面,然后去掉前置零,再用另外一个整型数组,来计算最后的结果。

#include<stdio.h>
#include<string.h>
int main()
{
    int n,w=1,m;
    scanf("%d",&n);
    m=n;
    while(n--)
    {
        int u=0;
        char a[1010],b[1010];
        scanf("%s%s",a,b);
        int l1=strlen(a);
        int l2=strlen(b);
        int x[1010],y[1010],z[1010];
        memset(x,0,sizeof(x));
        memset(y,0,sizeof(y));
        memset(z,0,sizeof(z));
        for(int i=l1-1,k=0; i>=0; i--,k++)
            x[k]=a[i]-'0';
        for(int i=l2-1,k=0; i>=0; i--,k++)
            y[k]=b[i]-'0';
        int l3=l1>l2?l1:l2;
        for(int i=0; i<=l3; i++)
        {
            z[i]=x[i]+y[i]+u;
            u=z[i]/10;
            z[i]=z[i]%10;
        }
        for(int i=l3; i>=0; i--)
            if(z[i]!=0)
            {
                l3=i;
                break;
            }
        printf("Case %d:\n%s + %s = ",w++,a,b);
        for(int i=l3; i>=0; i--)
        {
            printf("%d",z[i]);
        }
        printf("\n");
        if(w<=m)
            printf("\n");
    }
    return 0;
}
 

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值