BZOJ 1620: [Usaco2008 Nov]Time Management 时间管理【二分】

1620: [Usaco2008 Nov]Time Management 时间管理

Time Limit: 5 Sec Memory Limit: 64 MB

Description

Ever the maturing businessman, Farmer John realizes that he must manage his time effectively. He has N jobs conveniently numbered 1..N (1 <= N <= 1,000) to accomplish (like milking the cows, cleaning the barn, mending the fences, and so on). To manage his time effectively, he has created a list of the jobs that must be finished. Job i requires a certain amount of time T_i (1 <= T_i <= 1,000) to complete and furthermore must be finished by time S_i (1 <= S_i <= 1,000,000). Farmer John starts his day at time t=0 and can only work on one job at a time until it is finished. Even a maturing businessman likes to sleep late; help Farmer John determine the latest he can start working and still finish all the jobs on time.
N个工作,每个工作其所需时间,及完成的Deadline,问要完成所有工作,最迟要什么时候开始.

Input

  • Line 1: A single integer: N
  • Lines 2..N+1: Line i+1 contains two space-separated integers: T_i and S_i

Output

  • Line 1: The latest time Farmer John can start working or -1 if Farmer John cannot finish all the jobs on time.

Sample Input

4
3 5
8 14
5 20
1 16
INPUT DETAILS:
Farmer John has 4 jobs to do, which take 3, 8, 5, and 1 units of time, respectively, and must be completed by time 5, 14, 20, and 16, respectively.

Sample Output

2
OUTPUT DETAILS:
Farmer John must start the first job at time 2. Then he can do the second, fourth, and third jobs in that order to finish on time.

题解

可以二分这个开始时间,然后O(n)check一趟就可以了。

代码如下

#include<cstdio>
#include<algorithm>
using namespace std;
int L,R=1e9,n,Ans=-1;
struct xcw{
    int T,S;
    bool operator <(const xcw b)const{return S<b.S;}
}a[1005];
bool check(int Now){
    for(int i=1;i<=n;i++)
    if(Now+a[i].T<=a[i].S) Now+=a[i].T;else return 0;
    return 1;
}
int main(){
    #ifndef ONLINE_JUDGE
    freopen("prob.in","r",stdin);
    freopen("prob.out","w",stdout);
    #endif
    scanf("%d",&n);
    for(int i=1;i<=n;i++) scanf("%d%d",&a[i].T,&a[i].S),R=min(R,a[i].S);
    sort(a+1,a+1+n);
    for(int mid=(R+L)>>1;L<=R;mid=(R+L)>>1)
    if(check(mid)) L=mid+1,Ans=mid;else R=mid-1;
    printf("%d\n",Ans);
    return 0;
}

转载于:https://www.cnblogs.com/XSamsara/p/9043179.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值