(PAT 1110) Complete Binary Tree (判断完全二叉树)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

解题思路:

二叉树数组的存储方式是根据层序遍历来存储的

左子树的下标为root*2 右子树下标为root*2+1

我们通过先序遍历,每次遍历时带上结点的下标,遍历完成后,我们将得到一个最大下标

如果这个最大下标 == 结点个数,那么这颗树就是完全二叉树(因为我们知道,完全二叉树是被挤满的)

#include <iostream>
#include <algorithm>
#include <math.h>
#include <string.h>
#include <queue>
using namespace std;
const int MAXN = 50;
struct MyStruct
{
	int lchild = -1;
	int rchild = -1;
	bool notRoot = false;
}BTree[MAXN];
int N;
int maxn = -1;
int ans = -1;
void DFS(int root, int index) {
	if (index > maxn) {
		maxn = index;   //寻找最大下标
		ans = root;
	}
	if (BTree[root].lchild != -1) DFS(BTree[root].lchild, index * 2);
	if (BTree[root].rchild != -1) DFS(BTree[root].rchild, index * 2 + 1);
}
int main() {
	scanf("%d", &N);
	for (int i = 0; i < N; ++i) {
		char lc[5], rc[5];
		scanf("%*c%s %s", lc,rc);
		if (strcmp(lc, "-") == 0 && strcmp(rc, "-") == 0) {
			BTree[i].lchild = -1;
			BTree[i].rchild = -1;
			BTree[BTree[i].lchild].notRoot = true;
			BTree[BTree[i].rchild].notRoot = true;

		}
		else if (strcmp(lc, "-") == 0 || strcmp(rc, "-") == 0) {
			if (strcmp(lc, "-") == 0) {
				BTree[i].lchild = -1;
				BTree[i].rchild = atoi(rc);
				BTree[BTree[i].rchild].notRoot = true;
			}
			else if (strcmp(rc, "-") == 0) {
				BTree[i].lchild = atoi(lc);
				BTree[i].rchild = -1;
				BTree[BTree[i].lchild].notRoot = true;
			}
		}
		else {
			BTree[i].lchild = atoi(lc);
			BTree[i].rchild = atoi(rc);
			BTree[BTree[i].lchild].notRoot = true;
			BTree[BTree[i].rchild].notRoot = true;
		}
	}
	int nRoot = -1;
	for (int i = 0; i < N; ++i) {
		if (BTree[i].notRoot == false) {
			nRoot = i;
			break;
		}
	}
	//遍历寻找最大下标
	DFS(nRoot, 1);
	if (maxn == N) {
		cout << "YES" << " " << ans << endl;
	}
	else {
		cout << "NO" << " " << nRoot << endl;
	}

	system("PAUSE");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值