【完全二叉树规律】1110 Complete Binary Tree (25 分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -
结尾无空行

Sample Output 1:

YES 8
结尾无空行

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -
结尾无空行

Sample Output 2:

NO 1
结尾无空行

Code

#include <iostream>
using namespace std;
struct node{
	int left;
	int right;
}a[1000];
int maxn = -1, ans;
void dfs(int root, int index){
	if(index > maxn){
		maxn = index;
		ans = root;//这是最后一次遍历到的位置会进去的 
	}
	if(a[root].left != -1)	dfs(a[root].left, index * 2);
	if(a[root].right != -1) dfs(a[root].right, index * 2 + 1);
}
int main(){
	int n;//number from i to n -1
	cin>>n;
	bool isChild[600];
	for(int i = 0; i < n; i++){
		string l, r;
		cin>>l>>r;
		if(l == "-"){
			a[i].left = -1;
		}else{
			a[i].left = stoi(l);
			isChild[a[i].left] = true;
		}
		if(r == "-"){
			a[i].right = -1;
		}else{
			a[i].right = stoi(r);
			isChild[a[i].right] = true;
		}
	}
	int i;
	for(i = 0; isChild[i] == true;)
		i++;
	int root = i;
	dfs(root, 1);
	if(maxn == n)
		cout<<"YES "<<ans;
	else
		cout<<"NO "<<root;
	
}

Summary

如果是完全二叉树的话,根的左右和下标关系是有关系的,left = 2 * root ,right = 2 * root + 1,所以可以遍历最大的下标,最大下标 = 总的节点数(完全二叉树),如果最大下标 >结点数就不是了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_Amonlisa

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值