(PAT 1040) Longest Symmetric String (DP-最长回文子串)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

解题思路:

最长回文字串问题:

#include <iostream>
#include <algorithm>
#include <string>
#include <string.h>
using namespace std;
const int MANX = 1010;
string input;
int sdp[MANX][MANX];
int main() {
	getline(cin, input);
	int len = input.length();
	memset(sdp, 0, sizeof(sdp));
	int ans = 1;
	for (int i = 0; i < len; ++i) {
		sdp[i][i] = 1;
		if (i < len - 1) {
			if (input[i] == input[i + 1]) {
				sdp[i][i + 1] = 1;
				ans = 2;
			}
		}
	}
	//状态转移
	for (int i = 3; i <= len; ++i) {
		for (int j = 0; j + i - 1 < len; ++j) {
			int k = j + i - 1;
			if (input[j] == input[k] && sdp[j + 1][k - 1] == 1) {
				sdp[j][k] = 1;
				ans = i;
			}
		}
	}
	cout << ans << endl;

	system("PAUSE");
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值