(PAT 1075) PAT Judge (排序)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​4​​), the total number of users, K (≤5), the total number of problems, and M (≤10​5​​), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

解题思路:

创建若干张哈希表,用来保存题号学号与分数之间的关系

题目判定分为满分,为满分,0分,编译不通过,没提交。在最后统计成绩时进行判定就可以了

这题的坑点是0分,未通过编译算零分,题目答错也算零分,但是全部未通过编译就不输出该用户,有题目拿0分,就算只是一道,也要输出用户

比如 总成绩 0: - - 0 -

这样的特殊情况也是要输出的

#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
using namespace std;
const int MAXPro = 6;
const int MAXUsers = 10010;
int N, K, M;
vector<int> nameList;
int gradeList[MAXPro][MAXUsers];
int fullmarkList[MAXUsers];
int fullpros[MAXPro], sumOfPerfectpro[MAXUsers];
bool isappear[MAXUsers];
bool isac[MAXPro][MAXUsers];
bool cmp(int ida, int idb) {
	if (fullmarkList[ida] != fullmarkList[idb]) return fullmarkList[ida] > fullmarkList[idb];
	else {
		if (sumOfPerfectpro[ida] != sumOfPerfectpro[idb]) return sumOfPerfectpro[ida] > sumOfPerfectpro[idb];
		else {
			return ida < idb;
		}
	}
}
int main() {
	fill(gradeList[0], gradeList[0] + MAXUsers * MAXPro, -2);
	fill(isac[0], isac[0] + MAXUsers * MAXPro, false);
	fill(fullmarkList, fullmarkList + MAXUsers, 0);
	fill(isappear, isappear + MAXUsers, false);
	fill(sumOfPerfectpro, sumOfPerfectpro + MAXUsers, 0);
	scanf("%d %d %d", &N, &K, &M);
	for (int i = 1; i <= K; ++i) {
		scanf("%d", &fullpros[i]);
	}
	int userID, proId, score;
	for (int i = 0; i < M; ++i) {
		scanf("%d %d %d", &userID, &proId, &score);
		if (!isappear[userID]) {
			isappear[userID] = true;
			nameList.push_back(userID);
		}
		gradeList[proId][userID] = gradeList[proId][userID] < score ? score : gradeList[proId][userID];
		if (score == fullpros[proId] && isac[proId][userID] == false) {
			sumOfPerfectpro[userID]++;
			isac[proId][userID] = true;
		}
	}

	for (int i = 0; i < nameList.size(); ++i) {
		for (int j = 1; j <= K; ++j) {
			if (gradeList[j][nameList[i]] > -1) {
				fullmarkList[nameList[i]] += gradeList[j][nameList[i]];
			}
		}
	}
	sort(nameList.begin(), nameList.end(), cmp);
	int oder = 1;
	int maxSocre = 0x3fffffff;
	int inoder = 1;
	for (int i = 0; i < nameList.size(); ++i) {
		if (fullmarkList[nameList[i]] > 0) {
			if (fullmarkList[nameList[i]] < maxSocre) {
				inoder = oder;
				maxSocre = fullmarkList[nameList[i]];
			}
			printf("%d %05d %d", inoder, nameList[i], fullmarkList[nameList[i]]);
			for (int j = 1; j <= K; ++j) {
				if (gradeList[j][nameList[i]] > -1) {
					printf(" %d", gradeList[j][nameList[i]]);
				}
				else if (gradeList[j][nameList[i]] == -1) {
					printf(" 0");
				}
				else {
					printf(" -");
				}
			}
			printf("\n");
			oder++;
		}
		else {  //特殊情况:有题目拿了零分,而不是全不通过编译,也要输出
			bool iszero = false;
			for (int jk = 1; jk <= K; ++jk) {
				if (gradeList[jk][nameList[i]] == 0) {
					iszero = true;
					break;
				}
			}
			if (iszero) {
				if (fullmarkList[nameList[i]] < maxSocre) {
					inoder = oder;
					maxSocre = fullmarkList[nameList[i]];
				}
				printf("%d %05d %d", inoder, nameList[i], fullmarkList[nameList[i]]);
				for (int j = 1; j <= K; ++j) {
					if (gradeList[j][nameList[i]] > -1) {
						printf(" %d", gradeList[j][nameList[i]]);
					}
					else if (gradeList[j][nameList[i]] == -1) {
						printf(" 0");
					}
					else {
						printf(" -");
					}
				}
				printf("\n");
				oder++;
			}
		}
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值