Six Degrees of Cowvin Bacon POJ - 2139 (Floyd-warshall算法模板)

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon". 

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case. 

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows. 

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were. 

Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows. 

Sample Input

4 2
3 1 2 3
2 3 4

Sample Output

100

解题思路:

利用该算法可以得出任意两点间的最短路径,最后逐个累加求出最小的平均值

注意初始化时,要把结点自己到自己的权值赋为0,到其他结点的权值赋为0x3f

#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <stdio.h>
using namespace std;
const int MAXN = 310;
const int INF = 0x3fffffff;
int N, M;
int dmap[MAXN][MAXN];  

void warShall_flody() {
	for (int k = 0; k < N; ++k) {
		for (int i = 0; i < N; ++i) {
			for (int j = 0; j < N; ++j) {
				dmap[i][j] = min(dmap[i][j], dmap[i][k] + dmap[k][j]);
			}
		}
	}
}

int main() {
	scanf("%d %d", &N, &M);
	memset(dmap, 0x3f, sizeof(dmap));    //必须赋值赋成0x3f
	for (int i = 0; i < N; ++i) dmap[i][i] = 0;
	int nums, snode;
	for (int i = 0; i < M; ++i) {
		scanf("%d", &nums);
		vector<int> tnodes;
		for (int j = 0; j < nums; ++j) {
			scanf("%d", &snode);
			tnodes.push_back(snode-1);  //把边插入
		}
		//插入到邻接矩阵中

		for (int k = 0; k < tnodes.size()-1; ++k) {
			for (int v = k + 1; v < tnodes.size(); ++v) {
				dmap[tnodes[k]][tnodes[v]] = dmap[tnodes[v]][tnodes[k]] = 1;  //把边权设为1
			}
		}
	}
	warShall_flody();  //算出两点之间的最小值
	int minAve =  INF;
	for (int i = 0; i < N; ++i) {
		int tempMin = 0;
		for (int j = 0; j < N; ++j) {
			tempMin += dmap[i][j];
		}
		minAve = min(minAve, tempMin);
	}
	printf("%d\n", minAve*100/(N-1));

	system("PAUSE");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值