杭电NEU 动规专题 A

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 
Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 


Output

很水一道题,不过因为是第一题,就发出来吧。

题干很简单,最长子串和。

特别之处在于:输出路径 

要求输出第一次出现最大值的路径。

两种思路

1.反着写前缀和,时间承受不住。

2.DP,当然也是反着写。

反着写的目的就是  方便统计最后一次出现最大值,即为所求。



直接贴代码

#include <cstdio>
#include <cstring>

int main()
{
	int t,n;
	int sum[100010];
	int tt = 0;
	long long max,ans;
	int ansl,ansr;
	int r;

	scanf("%d",&t);
	tt = t;
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0 ; i!=n ; ++i)
			scanf("%d",&sum[i]);

		r = n-1;
		max = -100000001;ans = 0;
		ansl = 0;ansr = 0;
		for(int i=n-1 ; i!=-1 ; --i)
		{
			ans += sum[i];
			if(ans >= max)
			{
				max = ans;
				ansl = i+1;
				ansr = r+1;
			}
			if(ans <= 0)
			{
				ans = 0;
				r = i-1;
			}
		}
		printf("Case %d:\n",tt - t);
		printf("%I64d %d %d\n",max,ansl,ansr );
		if(t) printf("\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值