18年春季第一题 PAT甲级 1144 The Missing Number (20分) 上限感很重要

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​^5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

 易错点

最大的整数的100000(5个0),所以数组要开100005。

检验的时候要考虑到如果超过这个数,要当作无效,不要读进数组。

输出的时候要考虑可能1到100000的每个数都出现了,那要输出100001。

满分代码

#include <iostream>
using namespace std;
int n,i,a[100005];
int main(){
    scanf("%d\n",&n);
    while(n--){
        scanf("%d",&i);
        if(i>0 && i<100001)a[i]=1;
    }
    for(i=1;i<=100001;i++){
        if(a[i]!=1){
            cout<<i;
            break;
        }
    }
    return 0;
}

如果喜欢我的文章,请给我点赞哦!

  • 5
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值