1049 Counting Ones (30 分)

36 篇文章 1 订阅

The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (≤ 2 30 2^{30} 230).

Output Specification:

For each test case, print the number of 1’s in one line.

Sample Input:

12
结尾无空行

Sample Output:

5
结尾无空行

解释:

找o-n,所有数,各位上的1的个数之和

枚举太耗时了,这里还是找规律

可以固定一个1,然后变动其他位,可以有多少种变化,这样就找到规律了

规律如下:

设当前是第k位,最低位k=0,k位上的数字为now,left代表k位左面的数字,right代表k为后面的数字

now==0 ans+=left* 1 0 k 10^k 10k

now==1 ans+=left* 1 0 k 10^k 10k+right+1

now>=2 ans+=(left+1)* 1 0 k 10^{k} 10k

#include<iostream>
#include<math.h>
using namespace std;
int main()
{
    int n,a=1,ans=0;
    int left,now,right;
    cin>>n;
    while (n/a!=0)
    {
        //当前位数左边的数
        left=n/(a*10);
        //当前位置上的数字
        now=n/a%10;
        //右边的数
        right=n%a;
        if(now==0) 
            ans+=left*a;
        else if(now==1) 
            ans+=left*a+right+1;
        else 
            ans+=(left+1)*a;
        a*=10;
    }
    cout<<ans;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值