1049 Counting Ones

The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (≤2^​30).

Output Specification:

For each test case, print the number of 1’s in one line.

Sample Input:

12

Sample Output:

5

思路

思路来源于别人的博客https://blog.csdn.net/CV_Jason/article/details/85112495
简要概括一下,计算某一位出现1的次数,就是把原数该位置为1,计算其左边数和右边数有多少种组合情况,使得到的数小于等于原数。

AC代码

#include <iostream>
using namespace std;

int main(){
	int n, sum = 0;
	cin>>n;
	int now, left, right, a = 1;
	while(n / a){
		now = (n / a) % 10;
		left = n / (a * 10);
		right = n % a;
		if(now == 0) sum += left * a;
		else if(now == 1) sum += left * a + right + 1;
		else sum += (left + 1) * a;
		a *= 10;
	}
	cout<<sum;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值