PAT A1144 2019.08.24 【水题】

1144 The Missing Number (20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

思路分析

这题说是水题也不为过

注意那个 data>100000 continue的操作 没有它最后一个点会有段错误

#include<cstdio>
#include<iostream>
#define MAX 99992999
using namespace std;

int map[MAX]={0};

int main()
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		int data;
		cin>>data;
		if(data<=0)continue;
        if(data>100000)continue;
		map[data]=1;
	}
	
	for(int i=1;i<MAX;i++)
	{
		if(map[i]==0)
		{
			cout<<i;
			break;
		}
	}
	
	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值