枚举+二分查找:百练算法题2456:Aggressive cows(牛栏问题)

问题描述:(网址:http://bailian.openjudge.cn/practice/2456)

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).
His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

输入:

* Line 1: Two space-separated integers: N and C(先输入牛栏数,再输入牛棚数)
* Lines 2..N+1: Line i+1 contains an integer stall location, xi(依次输入牛棚的坐标,注意是坐标,不是间隔距离)

输出:

* Line 1: One integer: the largest minimum distance

样例输入:

5 3 

样例输出:

3

问题的分析及解决:

这是一道美国的计算机奥赛题,核心思路是要用枚举+二分法来解决这个问题。

如果纯枚举的思路,我们假设牛与牛的初始距离d为最远的牛棚的坐标数/牛数,然后将牛一个个放进牛棚中,并且保证牛与牛直之间的距离是要大于d的。在满足大于d的条件下,如果牛都可以放进牛棚,那么这个d是满足的,否则d-1重复上述的放牛进牛棚的操作。这种方法是纯枚举的方法进行处理牛棚问题的,这样操作的话,问题的时间复杂度就变成N*N了。此时引入二分法来优化。之前是对d不停-1执行的操作,我们可以将通过二分法,不断将d的值进行缩减,最终获得期望的参数。

二分法的思路是,定义一个min和max参数,min初始值为0,max初始值为d。将d值尝试是否可以满足牛全部放入牛棚,如果不满足,取d=(min+max)/2,max的值变为d;如果满足,取d=(min+max)/2,min的值变为d。以此反复操作,直至max-min的值比1小,终止操作。

个人感想:

这道题折腾了好久,总是有一些细节的问题造成代码出现故障,比如,将牛作为计数时,在for循环中,从1开始,因为已经默认把一头牛放在一个牛栏中了,所以考虑的是第二头牛放置的牛栏位置。

在循环判断以及一些赋值参数的位置也会造成程序运行失败,细节非常的多。这道题即便是在思路上非常清晰,但是在撸码的过程中,还是会出现各种各样的问题的,需要细心应对。

代码

#pragma warning(disable:4996)
#include <stdio.h>
#include <algorithm>
using namespace std;

int N, C;//N为牛栏数,C为牛数
int a[100005];
bool judge(int d);
void solve();

int main()
{
	scanf("%d%d", &N, &C);
	for (int i = 0; i < N; i++)
		scanf("%d", &a[i]);
	solve();
	return 0;
}

void solve()
{
	sort(a, a + N);
	int max = a[N-1];//这个地方默认就写这么大,否则提交会失败
	int min = 0;
	int mid = max / C;
	while (max - min > 1)
	{
		if (judge(mid))
			min = mid;
		else
			max = mid;
		mid = min + (max - min) / 2;
	}
	printf("%d\n", min);
}

bool judge(int d)//判断当前的距离值d是否满足牛可以放入牛栏
{
	int last = 0;
	for (int i=1; i < C; i++)//这里i从1开始取,因为已经将一头牛放入一个牛栏中
	{
		int crt = last + 1;
		while (crt < N && a[crt] - a[last] < d) {
			crt++;
		}
		if (crt == N)
			return false;
		last = crt;
	}
	return true;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值