1144 The Missing Number-PAT甲级(数的排序+遍历)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

寻找在给出的列表中未出现的最小的正整数,先将给出的数进行排序,然后依次遍历排序好的数组中的每个数,如果与之前最小的正整数的差值不是1,输出相应的数字即可

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=100005;
int p[N];
int n;
int main(){
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",&p[i]);
	}
	sort(p,p+n);
	int first=0;
	for(int i=0;i<n;i++){
		if(p[i]<=0) continue;
		if((p[i]-first)>1){
			printf("%d\n",first+1);
			return 0;
		}else{
			first=p[i];
		}
	}
	printf("%d\n",first+1);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值