Built?

There are N towns on a plane. The i-th town is located at the coordinates (xi,yi). There may be more than one town at the same coordinates.
You can build a road between two towns at coordinates (a,b) and (c,d) for a cost of min(|a−c|,|b−d|) yen (the currency of Japan). It is not possible to build other types of roads.
Your objective is to build roads so that it will be possible to travel between every pair of towns by traversing roads. At least how much money is necessary to achieve this?

Constraints
2≤N≤105
0≤xi,yi≤109
All input values are integers.

输入

Input is given from Standard Input in the following format:

N
x1 y1
x2 y2
:
xN yN

 

输出

Print the minimum necessary amount of money in order to build roads so that it will be possible to travel between every pair of towns by traversing roads.

 

 

样例输入

3
1 5
3 9
7 8

 

样例输出

3

 

提示

Build a road between Towns 1 and 2, and another between Towns 2 and 3. The total cost is 2+1=3 yen.

题目大意:给你n个城市的坐标x,y,两个城市之间的距离为min(|a−c|,|b−d|),建造最短的路以便可以任意两个城市都可以到达。

思路:坐标离散化,将坐标先按照x排序,在按照,y排序,分别计算出城镇之间的距离大小

/*Du Jinzhi*/
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <cmath>
#include <math.h>
#include <cstring>
#include <string>
#include <queue>
#include <deque>
#include <stack>
#include <stdlib.h>
#include <list>
#include <map>
#include <utility>
#include <set>
#include <bitset>
#include <vector>
#define pi acos(-1.0)
#define inf 0x3f3f3f3f
#define ll long long
#define linf 0x3f3f3f3f3f3f3f3fLL
using namespace std;
int cur=0;

struct node
{
    ll x,y;
    int w;
} pp[100005];
struct edge
{
    ll u,v,w;
} e[100005];
int vis[100005];
bool cmp1(node a,node b)
{
    return a.x<b.x;
}
void add(int u,int v,int w)
{
    e[cur].u = u;
    e[cur].v = v;
    e[cur++].w =w;
}
bool cmp2(node a,node b)
{
    return a.y<b.y;
}
bool cmp(edge a,edge b)
{
    return a.w<b.w;
}
int find(int x)
{
	if(vis[x]==x)
	return vis[x];
	return vis[x] = find(vis[x]);
}
int main()
{
    int n;
    scanf("%d",&n);
    {
        for(int i=1; i<=n; i++)
        {
            vis[i]=i;
            scanf("%lld%lld",&pp[i].x,&pp[i].y);
            pp[i].w=i;
        }
        sort(pp+1,pp+n+1,cmp1);
        for(int i=2; i<=n; i++)
        {
            add(pp[i-1].w,pp[i].w,pp[i].x-pp[i-1].x);
        }
        sort(pp+1,pp+n+1,cmp2);
        for(int i=2; i<=n; i++)
        {
            add(pp[i-1].w,pp[i].w,pp[i].y-pp[i-1].y);
        }
        sort(e,e+cur,cmp);
        ll sum=0;
        for(int i=0;i<cur;i++)
        {
            int fx=find(e[i].u);
            int fy=find(e[i].v);
            if(fx != fy)
            {
                vis[fx]=fy;
                sum += e[i].w;
            }
        }
        printf("%lld\n",sum);
    }


    return 0;
}

 

内容概要:该题库专为研究生入学考试计算机组成原理科目设计,涵盖名校考研真题、经典教材课后习题、章节题库和模拟试题四大核心模块。名校考研真题精选多所知名高校的计算机组成原理科目及计算机联考真题,并提供详尽解析,帮助考生把握考研命题趋势与难度。经典教材课后习题包括白中英《计算机组成原理》(第5版)和唐朔飞《计算机组成原理》(第2版)的全部课后习题解答,这两部教材被众多名校列为考研指定参考书目。章节题库精选代表性考题,注重基础知识与重难点内容,帮助考生全面掌握考试大纲要求的知识点。模拟试题依据历年考研真题命题规律和热门考点,精心编制两套全真模拟试题,并附标准答案,帮助考生检验学习成果,评估应试能力。 适用人群:计划参加研究生入学考试并报考计算机组成原理科目的考生,尤其是需要系统复习和强化训练的学生。 使用场景及目标:①通过研读名校考研真题,考生可以准确把握考研命题趋势与难度,有效评估复习成效;②通过经典教材课后习题的练习,考生可以巩固基础知识,掌握解题技巧;③通过章节题库的系统练习,考生可以全面掌握考试大纲要求的各个知识点,为备考打下坚实基础;④通过模拟试题的测试,考生可以检验学习成果,评估应试能力,为正式考试做好充分准备。 其他说明:该题库不仅提供详细的题目解析,还涵盖了计算机组成原理的各个方面,包括计算机系统概述、数据表示与运算、存储器分层、指令系统、中央处理器、总线系统和输入输出系统等。考生在使用过程中应结合理论学习与实践操作,注重理解与应用,以提高应试能力和专业知识水平。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值