HDU 4586

There is a dice with n sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai yuan. What's more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.
 

Input

Input consists of multiple cases. Each case includes two lines.
The first line is an integer n (2<=n<=200), following with n integers a i(0<=a i<200)
The second line is an integer m (0<=m<=n), following with m integers b i(1<=b i<=n), which are the numbers of the special sides to get another more chance.
 

Output

Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.
 

Sample Input

6 1 2 3 4 5 6
0
4 0 0 0 0
1 3
 

Sample Output

3.50 0.00
 
大致题意:共有n个面,每个面上是你可以获得的钱数,其中有m个面可以获得翻多次得机会即b[i]次;求获得钱的期望;
开始的时候将这个题想复杂了,以为翻开一次之后就不能重复翻开那个面;
后来听大神说翻开之后是可以重复翻开的
每翻开一次,它的结果都是和第一次的结果是一样的;即sum/n;
翻开一次sum/n;翻开两次sum/n*(m/n);获得翻开多次的几率为m/n;
翻开三次 sum/n*(m/n)*(m/n);
sum/n+sum/n*(m/n)+sum/n*(m/n)*(m/n).....等比数列;
翻开次数是无限次,每次都有获得翻开多次的几率;
等比数列求和,取极限;
sum/n*(1-(m/n));
当n等于m时期望无限大;
#include <bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int sum=0;
        for(int i=0; i<n; i++)
        {
            int a;
            scanf("%d",&a);
            sum+=a;
        }
        int m;
        scanf("%d",&m);
        for(int i=0; i<m; i++)
        {
            int b;
            scanf("%d",&b);
        }
        if(sum==0)
            printf("0.00\n");
        else if(n==m)
            printf("inf\n");
        else
            printf("%.2lf\n",1.00*sum/(n-m));
        }
        return 0;
}

 
 
 

转载于:https://www.cnblogs.com/AC-dream/p/5712549.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值