HDU 4597 Play Game (DP 记忆话搜索)

101 篇文章 1 订阅

Play Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1456    Accepted Submission(s): 826


Problem Description
Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?
 

Input
The first line contains an integer T (T≤100), indicating the number of cases.
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer a i (1≤a i≤10000). The third line contains N integer b i (1≤b i≤10000).
 

Output
For each case, output an integer, indicating the most score Alice can get.
 

Sample Input
  
  
2 1 23 53 3 10 100 20 2 4 3
 

Sample Output
  
  
53 105
 

Source
2013 ACM-ICPC吉林通化全国邀请赛——题目重现

大体题意:
Alice和Bob玩一个游戏 两堆扑克牌,Alice先玩,他可以从两堆牌的上面或者下面选择一张牌,问最后Alice最大权值是多少?
思路:
记忆话搜索,令dp[l1][r1][l2][r2],表示从第一堆牌l1--r1中选择最优策略 和从第二堆牌l2--r2中选择最优策略。
那么当前最优解就是  当前的sum和(两堆的sum)减去  下一个人选择最优策略 ,取一个最大值就是当前的最优解!
详细见代码:
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cstdlib>
#include<cmath>
#include<iostream>
#include<sstream>
#include<iterator>
#include<algorithm>
#include<string>
#include<vector>
#include<set>
#include<map>
#include<deque>
#include<queue>
#include<stack>
#include<list>
typedef long long ll;
typedef unsigned long long llu;
const int maxn = 20 + 5;
const int inf = 0x3f3f3f3f;
const double pi = acos(-1.0);
const double eps = 1e-8;
using namespace std;


int a[maxn],b[maxn];
int suma[maxn],sumb[maxn];
int dp[maxn][maxn][maxn][maxn];
int dfs(int l1,int r1,int l2,int r2){
    if (l1 > r1 && l2 > r2)return 0;
    if (dp[l1][r1][l2][r2] != -1)return dp[l1][r1][l2][r2];
    int sum = 0,ans = 0;
    if (l1 <= r1){
        sum += suma[r1] - suma[l1-1];
    }
    if (l2 <= r2){
        sum += sumb[r2] - sumb[l2-1];
    }
    if (l1 <= r1){
        ans = max(ans,sum - dfs(l1+1,r1,l2,r2));
        ans = max(ans,sum - dfs(l1,r1-1,l2,r2));
    }
    if (l2 <= r2){
        ans = max(ans,sum - dfs(l1,r1,l2+1,r2));
        ans = max(ans,sum - dfs(l1,r1,l2,r2-1));
    }
    return dp[l1][r1][l2][r2] = ans;
}
int main(){

    int T;
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        memset(dp,-1,sizeof dp);
        for (int i = 1; i <= n; ++i){
            scanf("%d",&a[i]);
            suma[i] = suma[i-1] + a[i];
        }
        for (int i = 1; i <= n; ++i){
            scanf("%d",&b[i]);
            sumb[i] = sumb[i-1] + b[i];
        }
        printf("%d\n",dfs(1,n,1,n));
    }
    return 0;
}


 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值