【C++】1020. Tree Traversals (25)

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2


1.一次AC,只是过程调试的时候没理清楚,

2.用递归做的

#include <iostream>
#include <string>
using namespace std;

int post[31]={0},ino[31]={0},level[31]={0};

int max(int N){
	int mm=-1;
	for(int i=0;i<N;i++){
		if(level[i]>mm)
			mm=level[i];
	}
	return mm;
}



void find(int a1,int a2,int b1,int b2,int l){

	for(int i=b1;i<=b2;i++){
		if(post[a2]==ino[i]){
			level[i]=l;
			int ll=i-b1;
			if(ll!=0){
				find(a1,a1+ll-1,b1,i-1,l+1);
			}
			ll=b2-i;
			if(ll!=0){
				find(a2-ll,a2-1,i+1,b2,l+1);
			}
			break;
		}
	}
}

int main(){
	int N,i;
	freopen("in.txt","r",stdin);
	scanf("%d",&N);
	for(i=0;i<N;i++){
		scanf("%d",&post[i]);
	}
	for(i=0;i<N;i++){
		scanf("%d",&ino[i]);
	}
	find(0,N-1,0,N-1,1);
	int mm=max(N);
	bool ff=true;
	for(i=1;i<=mm;i++){
		for(int j=0;j<N;j++){
			if(level[j]==i){
				if(ff){
					ff=false;
				}else{
					cout<<" ";
				}
				cout<<ino[j];
			}
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值